Beta - froze on starting sequence

I downloaded the new Beta this evening. I have PHD2 2.5.0Pre3 installed on a W7 laptop. Upon clicking to start the sequence SGP froze, PHD2 froze and Eqmod froze: all 3 froze (not responding) the instant I pressed to start the sequence.

  1. I connected to my mount via CdC and Eqmod.
  2. I then connected to PHD2 (this is a change in my normal workflow as I usually start SGP before PHD2)
  3. I opened SGP with New Sequence with Profile, connected to all the equipment. After cooling I focused.
  4. I used the Framing Mosaic to create a new sequence.
  5. I then saved the sequence
  6. I then focused before Centering Now on my target.
  7. I then calibrated PHD2.
  8. I then clicked Sequence and everything froze, approx 22:00hrs.
  9. I had to Ctrl_Alt_Del to close everything down before re-booting.

Log file sg_logfile_20150411214151.txt (83.3 KB) .

I reverted to an earlier build,, after this and captured Lum data.

The end of the log says that PHD2 wasn’t connected, but it was guiding fine (I had allowed it to guide for a few minutes before clicking Sequence).

Any insight you can give will be appreciated.



I don’t really have any input per-say except to say that using a previous version “might” have just had the same effect as restarting the beta and trying again (releasing sockets, etc…). 2.4.0 and 2.4.1 do not differ wildly in PHD2 control. The only difference being that SGPro, upon detecting a bad socket connection should attempt to destroy it and create a new one. I don’t see anything in your logs indicating SGPro got to that point.

The one thing I do see is that your mount barfed when SGPro tried to sync it because it was parked. It should be harmless, but I don’t know if your mount might have been in a funny state after this.

If you are able to produce this consistently, we can dive deeper, but right now it looks like a “one-off” local socket issue.

Thanks Ken.

I don’t understand why there would have been a clash with synch/park as I unparked my mount before carrying out the Centre Now function. If I have inadvertantly not unparked before slewing or centering before, an error message pops up. Nothing llike that happened last night. Interestingly, I had upgraded to the latest Eqmod build as well.

I will revert to the new Beta tonight (forecast for clear skies again) and see what happens. I’ll report back.


I downloaded and used with TSX and PHD2 on a Paramount MX. It all worked very well indeed and I managed 4 hours of data and about 30 subs.

I made the mistake of upgrading my Lodestar driver though to the latest on the SX website. I could not get reliable connections and did go back to the prior driver level.

Hi Buzz,

Please tell us the SX driver version number that’s stable. I have, and saved on my computer. I had my Superstar stopped communicating twice during the Sequence run but I am not sure which SX version it was running.


On the SX website, I returned to the ‘prior one’ I had issues with
Mine is a Lodestar X2

I should know by now, ‘if it ain’t broke, don’t fix it’ !

Thanks Buzz. I am kind of the opposite. Even if it ain’t broke, I update anyway. Maybe not a good idea but I can always revert back to previous version. I wonder what was the reason for SX updating their driver in the first place. Did you report this to SX?


Clouds spolied a long imaging run but I managed 1 single 5 minute sub, and all seemed to be working fine and as expected. A one-off as you thought.
Many thanks,

Peter, Yes, I did report it to SX - but they have not acknowledged it so far. Website is unchanged.

I’m going for a home run tonight and will run the screen capture video too - fully automatic startup. If it goes to plan, SGP can use it if they choose.