(BETA) (64-bit) Testing

Last night I was able to test the 64bit beta. Everything went smoothly and all downloads with my cameras (ASI6200 and ASI2600) worked perfectly, and I thought the downloads were happening faster too but not by much. Note that I didn’t have any trouble with downloads in the 32bit version either.

However I did notice one oddity. I am unable to set the per event camera gain unless the camera is connected to SGP. Previously I could set that gain to whatever I want by either typing it in or choosing from the list. Now that area is greyed out.

Did something change?

We’ll take a look. Likely something additional was changed with the additional ASCOM changes around Gain/Offset.


I’m not sure if this matters but I’m still on ASCOM 6.4. I’ve been reluctant to update to 6.5 but it seems as though SP1 has solved the issues it had on release.


Where did you find the link for the 64-bit version? I couldn’t find anythiing on the Downloads page.


On the downloads page look for “SGPro Betas”. It’s one of the tabs on the left side like “current release” “SGPro 3 (32bit)” etc.

Not entirely sure what those issues were? I’ve been using 6.5 for a while now without any issues…but you also image a lot more than I do so there’s also that :smiley: We addressed the Offset issues for older ASCOM versions in the latest release (for real this time)


Coordinate conversion was broken and it messed with platesolving software. It was fixed in SP1 and everything appears to work now.

I have also been testing the 64-bit version with a ZWO ASI6200 and the download issues I was having with the 32bit version of SGP went away. Now I am not losing any frame at all.

Thanks a lot for all your work!


THere was a bunch of chatter on the Astro-Physics user groups about things being broken, and in other forums too, and it scared me off. But upon your recommendation I will update because after all I will do whatever you tell me to do Jared, benevolent overlord. :grinning:

Pretty sure @ken is the benevolent one :smiley: As for updating…there’s no need if you don’t want to. I was just relaying my limited real world experience with imaging with 6.5. Maybe one of these days my camera will get updated to 64bit drivers and I’ll get to use the 64bit version of SGP as well :smiley: but for now I’m stuck in 32bit land for my actual imaging.



I had clicked on “SG Pro 4 (64-bit)” and got a message that said there wasn’t a release available. I had also clicked on “SG Pro 4 (32-Bit)” and saw the betas there. I just didn’t realize there was a separate “Betas” tab. Thanks for pointing me in the right direction.


It did. I removed the ability to type freely here because it was causing some problems. I am going to add functionality here similar to the switches implementation that will allow you to pick a value that is valid for your camera even when the camera is disconnected (assumes there has been at least one successful connection to the camera).

So far the 64bit version works great, ASI6200 image saving problems are gone too :+1:

Recently, I joined subscription 3 to 4. Most of the future had no issues, though one problem appeared.

When opening the pro 4 64 bit, the alert of ‘Pegasus astro power box switch’ will always disturb the starting progress. and it will not disappear with delete button in the alert box. so, SGP will not start in very long time.
what is this....
Is it driver matter? or SGP matter?
older SGP pro3 did not had that problem.If I connected the box before the opening, it will not appear. Though I occasionally use SGP without Pegasus, such like DSLR on easy mount without guiding tools. I use Ascom 6.5sp1 on win 10 20H2.


Hi, I have seen the same problem but find that SGP will start eventually if you very quickly delete these Pegasus error screens. Hopefully a proper fix is in the pipeline.

The solution is to start the Pegasus software before starting anything else. Then the pegasus pop up error will not show up. Annoying, but works.

We have contacted Pegasus about the issue as their driver should let the client (SGPro) manage the connection and not attempt to control the UI without client request to do so. No response yet. You can feel free to contact them as well.

Hi, Mr. Ken and joelshort
Thanks so much. I expect them to solve this.


Hi, FarnhamMike

I’m glad to know I am not the only person on this issue.
Thank you.


I have been using the latest Betas in 32-bit without apparent issues and am wondering about switching to the 64-bit version. Is there any reason why I should stick with the 32-bit version for the time being?

I think all my drivers support 64-bit now, once I cleared out some old registry entries that the QHY driver loader did not remove.

We haven’t heard of any 64bit specific issues in some time. I can’t think of any reason to stick with 32bit unless you’re forced to because of a driver (sadly like I am :cry: )