Alnitak flat man control is not working

The first time attempting to take flats as part of a sequence with 4.x version, the Alnitak flat man lamp is being turned off at the start of every flat exposure for some reason. I’ve not experienced this behavior previously with SGP and this flat box.

With normal sequence flats, and frame and focus, the behavior is the same. I can see in the log file, the flat box lamp is being turned off. What’s going on with this?

As a work around, I disconnected the flat box from the sequence and controlled it manually with Alnitak sw so SGP would not turn it off. Then I captured the sequence flats as intended.

There was at least one report of similar behavior a few years ago on this forum. It was claimed the no filter flats setting required a brightness number > 0 (default). So I tried that and it did not change the behavior, lamp still shut off.

Adding log file message:

[05/20/23 22:21:41.233][DEBUG][Camera Thread][NONE] SGM_FRAME_AND_FOCUS message received…
[05/20/23 22:21:41.233][DEBUG][Camera Thread][NONE] Alnitak Flat Box2 - Setting Brightness to 0


You didn’t specify what version you were using, but assuming it’s the latest from the 4.2 series, we’ll be making a release today that will hopefully address this issue. I say “hopefully” because its cause is timing related and difficult to reproduce, but we think we have it figured out.

Thanks for responding Ken,


I’ll look for the new release and give the Alnitak control a try and send feedback.

I tried to submit an issue report a couple days ago and used the dialog to select a log file from the last night the problem was experienced. It was difficult to know if this process worked (the issue report).


HI, I downloaded Beta version, thanks for including a potential fix. Manual and in sequence simulated flat captures were attempted with Alnitak flat man. With manual frame and focus, the behavior is unchanged. Soon as “take one” is selected, the flatman lamp is turned off or set to 0, regardless of the previous level. The lamp remains off during the exposure.

Testing in a sequence (simulated with camera and filter wheel connected and flatman), when the sequence starts to run, the filter is setup, and the flatman lamp is actived. Next after a delay (few sec), the lamp flashes off and back on, then the image is captured, this was consistent for each exposure of the programmed set. Since I don’t have the telescope setup, I can’t tell if the timing of the lamp being toggled off then back on is all occurring prior to the exposure starting.

I have a log file, how can that be provided?


So maybe partial success?

This is as designed and unchanged for a while now. Frame and Focus always takes “light” frames and that causes the flat box to turn off and potentially open if it has a shutter.

A log of this would be good as I haven’t seen this with my FlipFlat. You can upload one via the help menu in SGP.

Thank you,

I’m not finding how to upload a log file in the help menu. A few days ago, attempted report a problem with a log file and got no response so I can’t tell if the log was received or not. Please send simple instructions to upload this log.


You can find guidance here:

How to Submit Logs in SGPro - Sequence Generator / SGPro Support - Main Sequence Software (

I’ve done the report a problem twice now related to the Alnitak control and selected a log file or two. There is no way for me to tell if the log was uploaded or a ticket was created. Can it please be confirmed if a ticket was created and if any of the logs were uploaded?


You seem to have 2 different users on the forum

Hi Ken and Jared,

Ok, I figured out what was going on with the log file upload. Sorry, my SGP session had my old forum name from previous use. It is there now from 5/23 testing at home under this current name.


Can the other username Starmen5 be deleted?

Im not really certain how to delete a user, but I did disable that account so you won’t be able to accidentally login to it