ASI1600 image download hangs (frame and focus routine)

Wondering where things are at with the ASI1600mm-c and problems working correctly with SGP?

In particular I am experiencing during frame and focus, that the image downloads stop, hang. It keeps taking frames (so it appears) but never updates the image on the screen.

I have not experienced problems when performing acquisitions runs where I’m collected data for an hour or more at 90sec and longer exposures.

Problem (for me) seems isolated to the frame and focus routine, short exposures and continuous.

Latest drivers and current SGP.

Log files from two night in a row.

Any input/suggestions are welcome.



I don’t think the problem is SGP. Are you running your guide camera and ASI through the same hub? That’s the only time I ever saw this exact problem, and when I did, it would routinely hang like this. Also In my case, only a reboot would reset whatever it was that was conflicting. Changing the download speed from 90 down to 45 had no effect, but as soon as I moved the ASI to it’s own USB 3 port on my laptop the problem disappeared. I have collected about 150 hours of data now at a download speed of 90 with no problems.


1 Like

Hi Larry. The problem was not with 90sec subs. Its during frame and focus. Short exposures (ie: 1sec, 2sec) and continuous for frame and focus. Now you’re point regarding adding another USB hub makes sense. I currently have everything running through one hub. I didn’t have problems this way when using a DSLR but it appears with the ASI1600 I perhaps can’t use just one USB hub. I will try adding another hub and report back.

Thanks for helping Larry!


Shawn, The “90” and “45” refer to the USB traffic rates you set for the ASI. Lower speed presumably helps with hanging problems, but did not solve it for me. The problem for me was also mostly with short F&F exposures of 1-9 seconds. However, it could also happen with longer ASI exposures, but not always and this is probably because there’s a conflict when both cameras try to download at the same time and that happens much more frequently when both camera are taking short exposures. I also never had a problem with both cameras on the same hub when I shot with a DSLR, so this is most likely a ASI or USB driver issue.

I believe I have my USB Limit set to around 45 or so. To be honest I didn’t notice a big speed difference between 45 and 90 but I did notice a difference in reliability! At 45 I have yet to have a single issue with well over 5000 frames, most of which are very fast intervals as I’m generally testing. Also this is on USB3.0.


I did lower to 70 for USB traffic. I will try powering the hub though first and then lower the traffic further. See what happens. Thanks for the help so far.


Thought I would update this. I’m still experiencing the frame and focus problem with even latest versions of SGP (.23 and .24).

It stalls indicating “downloading” but nothing happens. I have to disconnect the camera and reconnect. Its random though. Sometimes it happens sometimes it doesn’t. My USB traffic is set to 45.

Here’s a latest log file that this occured within.

Have you come to any fixes yet for this?



I am not sure if there is anything to fix from the SGPro side (I could be wrong). We have lots of ASI1600 users using FF with no apparent issues. This usually points to a problem with, settings, cables, hubs, power or the PC USB bus.

Thanks Ken. The settings are the same as they always have been, when things worked fine even. I would accept it could be cables or hub or something but that makes no sense since everything else connected works perfectly. I’m going to be trying things again tonight. Not yet at the point of throwing anything but this is getting frustrating.

Maybe if another ASI1600mmc user reads this and has no issues with FF, then they could post their settings. I know reading on CN this has been an issue in the past for many people. Could it somehow have reared its ugly head again for some reason?


This specific issue or the “out of memory” issue. I am not on CN very often… if folks are reporting issues there and not here, there is a good chance we are not aware of them.

What do you mean by everything else? That other things are using the hub and there are no issues? It may still be worth replacing cable and bypassing the hub all together. Different devices place different demands on a hub (including power).

Jared, How do you change the USB limits? I’ve looked everywhere and can’t find the settings.

There is a FW, SSAG and Rigel motor focus also attached to the powered hub. July 4th I ran into the problem and had to disconnect the camera and reconnect. July 5th and tonight (July 8th) there has been no issue with the frame/focus image downloading/stalling. Same powered hub, same devices connected and running. I’ll have to see if I have more time to commit to troubleshooting this and also get new cables and bypass the hub for testing. Not sure when/if that will happen though.

Click on the wrench (settings) icon for the camera and it will open the ZWO window that allows you to set gain/offset and USB limits.

I’ve had my 1600 for a little less than a week. I’m using usb 2.0, thru a powered usb hub and cat 6 ethernet connection. I have usb set to 80 and no problems with downloads.

Two problems that I have noticed are a noticeable rotation in the image with a meridian flip. Centered, but rotated about 4-7 degrees. I also noticed the rotation ( 7degrees) in images taken on the same side of the meridian on two consecutive nights. This has happened using a 10Micron mount with two different models of 60 -62 stars. Polar alignment was about 2’ rms. yes, the polar alignment could be made better, but it has never been a problem for the STT 8300m on a Tak FSQ 106, or the AGO 12.5" with Fli 11002m. Both platforms are on the 10u mount and I’ve never experienced rotation with my images before. On one of the evenings, I also imaged M8 with my larger scope before going to the 1600. Images from the FLI camera showed no rotation and stars were round.

The second problem is a noticeable tilt as evidenced in star elongation. I never had this problem with the STT 8300, so my guess is that a tilt tip adapter will have to be added. Stars were elongated in a diagonal and toward the corners.

As I watch the auto centering and plate solves being performed in SGP, they are all showing centering <= 1pixel

I had this problem with focusing run dropping and image runs dropping. I swapped out my active 3.0 usb cable for a new one and have not had one single hang or drop, focusing or imaging since doing so. See this thread and my link there. It may be of use.


This is the same thing that happens to me so much I have given up on it, but with the lockdown thought i would try again (and failed). connect just the camera and filterwheel, go on F&F take a 2 sec exposure, and it just hangs on the downloading, changed cables checked drivers, it is so frustrating that it dont work, sharpcap works ok, nina ok, firetrap, everything works except SGPRO, nightmare