ASI6200 Fails to save and plate solve overflow error

SGP has been working great for several months now but we recently purchased a ZWO ASI6200 and it began having issues with SGP immediately.

During a sequence with the 6200 a random number of exposures will throw a “failed to save” error and will not appear in the save directory, but the sequence will skip over it and proceed. Out of 50 subs maybe 5-10 won’t save.

Plate solving has also become unreliable. It will plate solve just fine for a few targets, and then the next target change after I go to sleep (of course), it will throw an “overflow” error. Worse, it will just sit on that error and not attempt to recover, try again or move forward in any way. The bulk of two nights have been lost due to that one.

I’m guessing that this has to due with the huge size of the 6200’s images.

I am able to save exposures via ZWO’s ASI capture software for hours with no issue, so it does not appear to be a USB issue (bandwidth is set to 40 just to be safe).

Help?

Last two night’s logs are in a google drive folder here:
https://drive.google.com/drive/folders/1M1Nc8uTgpbno_qkPMXs0WwXu8QDx7Och?usp=sharing

It might be worth trying the ASTAP solver, setup instructions here:
https://mainsequencesoftware.com/Content/SGPHelp/SettingupASTAP.html

I’m not sure about the “Failed to save”. I’ll see if I can duplicate that.

Jared

I have the same issues downloading images with both my 6200mm, on all my laptops. If it’s true it works fine with ZWO’s software that points to an issue with SGP. I might try out maxim or theskyx and see if I still have issues.

I get random errors during frame and focus, plate solves, and running sequences. Failed to download, failed to save to disk, Error 7 (I think), out of memory, etc. Disconnecting the camera from SGP and/or changing the gain settings temporarily resets the issues and I can begin downloading until it errors out again.

I bypassed my usb hubs and tried several different usb cables but still get problems. Just when I think it’s resolved it happens again. I haven’t yet tried the cable Joel recommended. Trying that cable and trying different capture software are my next steps.

Also make sure your ASCOM drivers are up to date and that you’re using the ZWO ASCOM driver ASI Camera (1) or 2 in SGP (it looks like the OP is)

The native driver in SGP is quite old at this point and will be sunset very soon.

Jared

Yes, I’m using the latest stable version of ASCOM and the latest ZWO ASCOM driver (ASI Camera 1). Completely removing all old software and reinstalling drivers, SGP, etc, is something I might also try.

I am using the Ascom ASI driver for the 6200 and am using the latest drivers from ZWO’s as well as ASCOM 6.4.

Binning reduces but does not eliminate the problem with plate solving, and from looking through the logs it looks like memory issues with saving. This system has 64GB of RAM so the hardware isn’t the bottleneck.

I’ll try that alternate plate solver tonight, but last night I still lost a good number of subs due to failure to save with the logs indicating memory issues again.

Can SGP/ASCOM handle the file sizes of these new IMX455 chips and their even larger siblings?

Yes. I’m using a ASI6200MM and ASI2600MC at the same time with SGP without issues. The download issues have nothing to do with RAM.

I know you say it is not a USB issue but I still think it is. When I first got the cameras I went through 3 different USB cables before I found one that worked 100% reliably for downloads, and even then I had to attach the camera directly to the computer and not through a USB hub. I have my ASI2600MC going through a high quality USB3 hub but if I put both cameras on the hub I have issues every 100 frames or so.

I just ran several tests with SGP and the 64 bit version of NINA. The results show with nearly 100% confidence there’s an issue with SGP. Nina worked flawlessly. Nina also downloads frames in 3 seconds compared to 8 seconds with SGP.

I used two identical rigs for testing (Edge 11, AP1100, ASI6200mm, ZWO OAG and EFW, ASI174 mini, startech usb hubs). The only difference between the two rigs were the laptops used. In order to stress test, on each rig I used long 9 ft usb 3 cables from the camera to each hub, then 15 ft usb 3 cables from each hub to each laptop. I also used the usb hub on the asi6200 connected to the EFW and ASI174 guide cams. I looped the ASI174 in phd2, turned on sidereal tracking, and turned on camera cooling for all tests. ASCOM drivers were used and the “USB Limit” was set to 40 (the minimum) for all testing.

Each test consisted of a sequence of 100 frames, 3 seconds per frame. In the results below, “Pass” means it properly downloaded all 100 frames; “Failed” means at least some of the frames didn’t download (usually several). The errors thrown on failure read: “Error attempting to capture image” and “Failed to save image to disk.” The tests are shown in order I performed them.

Nina Test 1
Rig 1 = Pass
Rig 2 = Pass

SGP Test 1
Rig 1 = Fail
Rig 2 = Fail

Nina Test 2
Rig 1 = Pass
Rig 2 = Pass

SGP Test 2
Rig 1 = Pass
Rig 2 = Fail

Nina Test 3
Rig 1 = Pass
Rig 2 = Pass

SGP Test 3
Rig 1 = Fail
Rig 2 = Fail

Nina Test 4
Rig 1 = Pass
Rig 2 = Pass

SGP Test 4
Rig 1 = Fail
Rig 2 = Fail

In summary, NINA worked properly 8/8 times, and SGP worked properly 1/8 times. Additionally, I tested non sequence imaging (i.e. frame and focus) and NINA worked every time but SGP would often fail and give the message “Error capturing during frame and focus.”

Logs for all of these tests are available if needed. Unfortunately, I need to stop using SGP until / if this gets resolved. I hope the developers get it figured out soon.

Chad

1 Like

Unfortunately it could also be the 32bit variant of the ASCOM driver that is exceeding it’s memory space and silently failing. We’ve had similar issues with ZWO drivers in the past. The 64bit variant allows the driver allows this behavior for much longer.

We’re working towards 64bit support, which will not be a panacea but will “allow” drivers to do this kind of thing much easier.

Jared

Chad and Jared, what I don’t understand is that I’ve been able to download literally thousands of images with both a ASI6200 and ASI2600 simultaneously without any dropped frames or download problems. Yet other people have issues. Am I just lucky?

Joel,
You had to go through many failed cables to find a 6 footer that works reliably. Even if one is found, who wants to use a 6 ft cable plugged directly into the camera? With that short of cable on my rigs laptop placement needs to be planned each image to accomodate meridian flips and where the scope is pointed. With Nina I can use any cables I want and send them through a hub via one usb to computers.

Why does Nina work with all usb cables but SGP doesn’t? Also, why does Nina download more than 2x faster than SGP? SGP’s platform or download methods must be less reliable and less efficient than Nina. Hopefully the developers get it worked out.

It’s doubtful. I’m guessing the two of you are on different versions of the driver or something is different beyond just a simple USB cable. When using ASCOM the communication between the Client (SGP) and the Hardware is completely abstracted. If something were specific to SGP in this case we’d see it across multiple camera lines like the QHY600 and other higher MP chip cameras.

We could certainly be better about download times. It’s not that the download times in SGP are any slower than any other application, we just do a lot of additional things that happen before the image is displayed, for instance star and image analysis that should really be in their own thread and not prior to displaying the image.

Jared

Well, obviously, I do. A 6ft cable is long enough to be routed from my camera through the mount, to my NUC computer attached to my pier. I have no worries about cable snags or planning meridian flips etc.
I’m not arguing with you or denying what you’re saying, just trying to understand why my setup works great and yours doesn’t.
Do you know what version of the native driver and ASCOM driver you are using? I’m using camera driver 3.0.0.7, ASCOM driver 1.0.3.28.

The ZWO native driver is also 3.0.0.7 and the ZWO ASCOM driver is also 1.0.3.28. I was on the verge of purchasing NUCs until I realized NINA works perfectly with all of my cables - I assume other capture software works as well. The 6 ft cables you recommended arrive tomorrow. 6 ft cables are a pain for my setups though so I’ll be using NINA for now.

Jared’s comment about 64 bit support not available yet for SGP is probably why the 6200+SGP is limited to certain 6ft cables. I hope the change is made soon. Joel, you seem like a perfectionist so I imagine you’re in favor of the upgrade.

A 6’ cable would not even make it out of our mount with sufficient slack for the scope to move in Dec. Requiring such short cables for reliable operation is untenable. Our installation uses startech powered USB hubs mounted to the telescope pier.

I don’t understand how cable length could be the culprit when other software is able to download hundreds of images without issue? Presumably hardware issues would hit all software?

Switching the plate solver to ASTAP solved the overflow issue, in fact it seems to work much faster and doesn’t have the annoying 10 second countdown after solving. So, hooray for that.

Unfortunately about half of the exposures taken last night failed to save, which is pretty atrocious. What is strange is that plate-solve and focus frames never fail to download, even at 1x1 binning. Between that and the fact that other software doesn’t have the same problem, it seems to me that the issue is not getting data from the camera to the PC (as in USB cables) but rather something SGP is doing with it once it arrives.

With how popular IMX455 chips are going to be, I hope a fix will come for this soon as its a dealbreaker.

Did anyone say that? I certainly didn’t. Somewhere in another thread I simply gave an example of a cable that worked for me, but that doesn’t have anything to do with the length of the cable (as long as it’s shorter than 15ft I think).

I’m glad that ASTAP solved one issue for you. Please understand that I do not have the necessary technical knowledge to know what is going on or how to fix it. I am simply giving an example of a combination of equipment that works for me 100% of the time with two ZWO cameras simultaneously with SGP.

In particular, I note that you are using a Startech USB hub. I also have a quality Startech USB 3 powered hub that I am using. However, no matter what I tried I could not get 100% download reliability if I connected the ASI6200 to that Startech hub. So I ran a cable directly from the camera to my NUC computer mounted on the pier and now I get 100% download reliability.

I still use the Startech hub for all my other equipment, including an ASI2600 and everything works perfectly.

I’ve tested with many different cables and length is a key factor. The shorter the cable the less download issues. That may not always be the case depending on the particular cable but there’s a strong correlation. That testing was done without a hub.

Working on a fix with ZWO at the moment.

Jared

2 Likes

Not that this pertains to the topic at hand but I am going to be buying this same camera as soon as I can.

That being said, I like to dabble in software and was using nina ealier tonight with my QHY16200A. First I used the QHY driver (not ascom) and the image hung on download. So I switched to the ASCOM driver. Did a few test exposures and it went fine. Then I started a sequence and it hung up again on the first image in the auto focus run.

I use an Icron Ranger 2304 which has been bullet proof for years.

I then gave up with nina for the night and launched SGP. No problems at all whatsoever.

I bring this up because unlike some of you guys in this thread I have the opposite issues. SGP works nearly flawlessly for me and has for a couple years now. Whereas everything else I try I end up with issues and deal breakers that convince me yet again that SGP is where I need to be. Now hopefully if Jared, per the post right above mine, found an issue with ZWO and the 6200 and is working it out, that’s great! Hopefully that’ll be resolved before I find money laying on the ground and can buy one. :slight_smile:

Hi there ,
I am having the same king of problem with SGP and the asi6200mm . I am using the ascom driver (1) . Sgp crashes randomly on frame and focus and sometimes in images saving . It crashes also very often (each time) in the flat calibration process .
More over sgp takes 4 seconds to upload the image . As sgp is not stable with this camera, I had to move to prism10 and use the regular zwo driver .
The regular zwo driver is fast . Quite instantaneous upload and do not crash . It is a pity that sgp does not handle the regular zwo driver because this camera could be the next future of astroPhotography and, I love sgp . Hope that this really big concern will be fixed soon . Crashes are a big concern but upload time also .
I tried : changing usb cables, takes the latest release of sgp, takes the latest release of ascom plateform .Nothing solves the problem.
It works fine with prism and zwo software so, it is not related to hardware problem.