local solver

I ran into a real curiosity last night when I tried to execute the Framing and Mosaic Wizard in my observatory. As I selected M82, SGPro failed to fetch and complained about “SIMBAD” with Object selected, and “” with coordinates selected.

I found that my Observatory computer (while presently off the internet) must have been previously using the internet to solve this exercise. I also found that my home computer was doing the same, because when I disconnected its internet, it also failed to fetch. I had thought that I was using the local solver all of this time.

This looks like the same issue Daniel brought up earlier in this thread. It looks like my server also could not start because address 8080 was already in use.

What now seems strange to me is that my observatory system has been able to do plate solving successfully during the night (i.e. moving from one target to the next) without an internet connection.

Does this make sense?

Appreciate your help,


If I’m not mistaken the Framing and Mosaic Wizard needs an internet connection to download (fetch) the images that are displayed in the wizard. That is totally separate from plate solving, which you can do without an internet connection if you have ansvr local astrometry on your machine.

1 Like

You’re rght. Framing and Mosaic Tool requires internet… plate solving with a local server does not.

Hi. I get the same message about the address alreay being in use. Nothing seems to be using it but I tried 1081 instead and got the same error. What other port values can be chosen? I have no idea whether 1082 etc is a good place to start. Also always seem to have to start ansvr manually. Any help much appreciated.

Honestly, any number just about. Try like 8085 or 4037.

Could it be that it is already running when you start it manually? (that would explain the port number being in use)
Did you try Start => Local Solver => Ansvr Settings to see if it is already running?
Do you see the ansvr shortcut in Start => Startup ?

Regarding the port number: as mentioned in another thread, run netstat -n -a -b from a command prompt to identify the program using the port, or run TCPView.

I would go up one number at a time (8080, 8081, 8082 …) until you find one available.


Ansvr settings results in a blank page noypt found unless I start Ansvr from the shortcut. After this I get the correct settings page. An Ansvr icon briefly appears in the task bar as my machine boots then disappears. I’ll check the the startup folder and try some other addresses. I’ve already run net stat and nothing seems to be using 8080 but I’ll try it again after starting Ansvr to see if it shows up. I presume it should if it’s running and the setting page is opening ok, thanks

yes, that is the ordinary, expected behavior. After that, ansvr should be running.

You could take a look at the log file to see if it reported an error and exited, or if it is still running. (Start => Local Solver => Watch Ansvr Log) We would want to see the log file before you manually start ansvr, since at that point we would be looking at the new log file when it is the first log file we are interested in.


Hi Andy. Thanks for the support. Booted machine this morning and ansvr stated ok. I tried blind solving an M33 fits image which I know solves when done through the internet. This is my log file:

[2014-11-23 10:49:51] ansvr 0.15 start
[2014-11-23 10:49:51] loading config from /var/tmp/platesolve/config
[2014-11-23 10:49:51] read port 8080 from reg
[2014-11-23 10:49:51] using scale error override value percent
[2014-11-23 10:49:51] using downsample
[2014-11-23 10:49:51] solution coordinates will use epoch J2000
[2014-11-23 10:49:51] saving config to /var/tmp/platesolve/config
[2014-11-23 10:49:51] [Server /opt/ansvr/ansvr accepting clients on port 8080]
[2014-11-23 10:52:59] [Connect from]
[2014-11-23 10:52:59] GET /api/config HTTP/1.1
[2014-11-23 10:52:59] [Connect from]
[2014-11-23 10:53:11]
[2014-11-23 10:53:11] serve notfound uri =
[2014-11-23 10:53:11] [Connect from]
[2014-11-23 10:53:11] GET /favicon.ico HTTP/1.1
[2014-11-23 10:53:11] serve notfound uri = /favicon.ico
[2014-11-23 10:53:11] [Connect from]
[2014-11-23 10:53:30]
[2014-11-23 10:53:30] serve notfound uri =
[2014-11-23 10:57:00] [Connect from]
[2014-11-23 10:57:00] POST /api/config/login HTTP/1.1
[2014-11-23 10:57:00] saving config to /var/tmp/platesolve/config
Waiting for data… (interrupt to abort)

Running netstat gives this:

Active Connections

Proto Local Address Foreign Address State
TCP db3msgr6011009:https ESTABLISHED
TCP snt-re3-8c:http ESTABLISHED
There was 1 more entry I think but the window closed before I could copy it. It definitely wasn’t the 8080 port though.

Do you think I need to reinstall ansvr with a different port? Tried 8081 last night but no luck. Help is much appreciated. Thank you

Okay, seem to have this working now but not sure what is different. It seems fine on 8080! Only issue now seems to be it timed out trying to solve an image of M33 which took only 18 seconds via the net. Maybe I have downloaded too many index files. I downloaded just about all of them. Should I remove some of them and if so which ones, the wide or very smallest fields? Or am I barking up the wrong tree here?
Thanks again

Forgive me… I’m a total newbie to SGP. I don’t have Internet Access where I image, so I thought: “ah ha, local plate solving is for me.” But the version of SGP I’m using, (the latest, I believe), doesn’t have any settings for that let me tell it there’s a local server. Is that because SGP knows enough to look for it? Am I doing something foolish?



No, you need to tell SGP where to find it. The ansvr setup details setting up SGP to use the local instance.


1 Like

Okay. Thank you. I looked harder at the instructions. The appropriate settings are in “Control Panel” not “Equipment Profile.”

Now, if the clouds will go away for a night or two, I’ll test this out.

Be well,


Hi Jared,

I jumped into local plate solving also with, and followed the online instructions. is installed and ansvr is working.
There is one point where I am bumped: in SGPRo, I don’t see the “Other” button on the Plate solving tab, so I cannot enter the local address as mentioned in step 14. I am using SGpro 2.4.1. Any ideas ?



Hi Andy,

Thnks, I found it, was my fault… :grinning:. I was looking at the wrong panel, now it works fine !!


Port numbers 8080-8081 were not available and so I re-installed to port 8082 which was.
After the install I checked via the cmd prompt netstat -n -a -b to check my ports again only to find port 8082 used by LMS.exe.I canßt seem to get a port working without some other process taking over.
Here is a copz of my log file.


You’re on the right track. On Windows 7 or later you can try any port number below 49152; on Windows XP you can try any port outside the range 1025–5000. You are bound to find one that is not in use eventually, just keep trying.


  • have tried 20 or so different port numbers but still no luck.
    Using it online works.*

That makes me think there is something else preventing it. The most likely candidate would be Windows Firewall. You should try temporarily disabling Windows Firewall to rule that out.