Astrometry.Net On center every time / Plate solve2 Way off every time Ioptron CEM60 SOLVED

I have read quite a few posts on here with this same issue and no fix. Many say is because Platesolve 2 uses J2000 & my Ioptron mount uses Jnow & sg pro does not translate properly?. When i switched to local Astrometry.Net solver & changed the settings to JNow it centers every single time.

My beef is i would rather use Platesolve 2 because of the speed. My mount does not have an option to use J2000 So i am asking can anything be done to correct the issue with Platesolve 2 & sg-pro.

See attached photos. I don’t even need to center after using Astrometry.Net. All settings in both programs are identical.

As SG-Pro is responsiable for translating there J2000 to Jnow that is the only thing i can come up with. There is no option for Ioptron to use J2000. Need SG-Pro support please.

When used with SGP both PlateSolve2 and are solving to J2000. SGP uses J2000 internally which make sense because J2000 is what is used by most star catalogs. And, yes SGP does translate to JNow before a slew. I used to have a IOptron mount and I never had a problem with either solver. Carefully review how you have the two solvers configured also check to be sure the time and latitude/longitude are set up correctly on your mount as well as the time on your computer. The conversion to JNow uses your time and location information so it has to be accurate.

1 Like

As i mentioned above every setting is identical and Local server is using Jnow not J2000 ansr

SGP is assuming J2000 for both solvers so that is not the right setting. If you change it to J2000, I think you will find the it agrees with PlateSolve2. SGP is expecting J2000 results and if your scope is not centering on that location you have some other problem. Again, check your scope time and location coordinates as well as your computer time. Those are involved in the conversion from J2000 to JNow. SGP uses a standard ASCOM library to do this conversion and it is well tested by many users.

An other (unlikely) possibility is the ASCOM driver for your scope is reporting it is a J2000 mount.

SGP is not the issue - there is something wrong about how your mount or driver is set up.

If sg is not the issue why are there so many threads on the same subject? I thank you for you help but I know my settings are correct as i went over them a thousand times & i am telling you that when i had local set to J2000 i was getting the same results as platesolve2 off to the right top corner every time yet when i changed it to JNow it put it dead center on every try. Do you honestly think that was by chance? My time server syncs with atomic clock every 5 minutes & the mount is synced with the PC at the start of each session.

I even tried All Sky plate solver and that matched my local server solves dead on. the only thing i can think of is my hand controller is taking the sync as a modeling point which is why SG put the option under telescope for sync behavior but i am not sure of those settings. Many people had the same exact issue with mounts using JNow

. sg

The threads you quote are three years old and they are not particularly relevant. I know it is frustrating, but if you insist on blaming SGP I don’t think you are going to find the problem. I have an IOptron mount and it works fine with SGP. I can’t diagnose from afar but everything you are seeing strongly suggest a mount or driver problem. I suggest you do a small test run - Connect your equipment, do a Center here on your target, then exit SGP. Then locate the log file for the test run and look at it. You will be able to see the interaction with the mount - in particular see whether the mount reports being a J2000 or JNow.
If you are not comfortable with that, post the log file here and let’s see what is happening. The important thing is to keep the test run as short as possible.

1 Like

You are not reading what i posted. Look at the photo i just posted. Do you see the settings “target offset” scope offset & none?" There were put there to correct issues like this. No one is blaming the software in fact is is probably ioptron who caused this in there firmware. Please let someone from SG respond. Thank you for trying to help. If my skies were clear i would be outside resolving this instead of writing inhere.

Ioptron Firmware
"Alignment model will roam between the hand controller, RS-232 port connection and Wi-Fi connection now. If you want to use any pointing enhancement software, such as T-Point, make sure there is no alignment model in the system! "

All items in your list were completed and here are the log files i have. i hope they are correct logs you are looking for. Please see above as it shows what i think is wrong and what i have done so far to trouble shoot. I think you have seen this issue before. I have uninstalled everything inc ascom and mount drivers then reinstalled all and still no change. I was using the ioptron commander to slew so there may be some information missing but i hope not. Thank you!

Dont know if this will help but these are all my settings in both platesolve 2 and ansvr.



ctrl pnl

SGP translates between JNow and J2000 provided the mount tells us what coordinate system it is using. From your logs it seems that the telescope seems to think it’s in J2000:

[03/20/18 00:32:23.057][DEBUG] [Telescope Thread] Telescope equatorial system is J2000…

So if the mount uses JNow it’s telling us that it’s in J2000 and thus we’re sending in J2000 coordinates when we sync or slew. I’m not sure if this is a common issue with iOptron mounts, but if they’re truly expecting JNow coordinates then their ASCOM driver will need to be adjusted to report the correct equatorial system.


This is bizarre but i knew it was off as looking at my logs it never showed JNow always J2000. I am in contact with Ioptron Support & they are monitoring this thread.

Wound up being a bug in the Commander ascom driver.
New driver not on website yet but they emailed me a copy and this is the result. SG now reporting mount wants JNow. Fixed in 2 days. I am impressed! Way to go Ioptron. Thanks for the assistance Jared.

[03/25/18 23:49:00.305][DEBUG] [Telescope Thread] Telescope: CanSetSideOfPier returned False
[03/25/18 23:49:00.305][DEBUG] [Telescope Thread] Telescope: CanPark returned True
[03/25/18 23:49:00.305][DEBUG] [Telescope Thread] Telescope equatorial system is JNOW…
[03/25/18 23:49:00.309][DEBUG] [Telescope Thread] SGM_TELESCOPE_CONNECT complete…
[03/25/18 23:49:00.370][DEBUG] [Main Thread] Telescope: Setting sync behavior to: Sync

I had had a similar problem - hope this will fix it.
I just checked the iOptron website and they have posted Ascom driver 5.6.3 dated 2018-02-06, but the update notes do not mention JNow or J2000 and the date is before your post. What is the version you received?
Could you send a copy to me?
Fred Klein