Attempt to Flip Now

Automatic Meridian Flip generally works like a dream for me. However if I’m taking long subs, for example 20 minutes, eventually you come accross the scenario where the meridian flip is due in say 19 minutes time. So SGP quite correctly waits & the timer counts down. If I just simply wait then SGP will perform the flip without a problem. But if I opt for the Attempt Flip Now option (in the hope of saving a few minutes of valuable imaging time) then it will always fail. In practice the flip does not take place, the counter continues running but becomes negative and the mount just continues to track. If allowed to continue the scope collides with the pier. Therefore manual intervention is required to abort the sequence.

It would be nice to resolve despite it not being critical as I have the option of just not interferring with the process. After all the button is labelled “Attempt” so what needs to be in place for a successful attempt I’m not sure? I have always had this problem even from even from earlier SGP revisions so I suspect the issue is with my mount driver but just in case it’s not I’ve attached the event log from the other night.

The start of the flip process begins on line
[07/12/20 01:42:44.139][DEBUG][Sequence Thread][SQ;] Checking if Meridian Flip is needed

The log actually implies that the side of pier changed but in reality it did not.

The log can be found at!AneSiXQRo7pri2Sa2ordTrcfM2Ld?e=Yyu41h

Any comments would be welcome.

Your mount does not support flipping prior to being at the actual meridian:

[07/11/20 22:59:19.590][DEBUG][Telescope Thread][NONE] Telescope: CanSetSideOfPier returned False

So manual flips will likely work…BUT you’ll need to wait until the mount tracks past the meridian to initiate one.

Unless you have a situation where something will run into your tripod/pier you probably don’t need to use the “Wait For Meridian” option and you can try just flipping once your mount is at or past the meridian so you’re not wasting time waiting to track to the meridian.


Hi Jared & thanks for the reply.
Yes you are correct my mount\mount driver does not support flipping before the meridian because it cannot set the sideOfPier. So thats why I always set it to flip at 35 miniutes past the meridian. I use 35 minutes because it’s half the maximum distance my mount can track (worse case scenario) before striking the pier. So hopefully if the flip were to fail then at least i’ve acquired one more image out of the sequence & still have time to dash out to the dome & prevent the collision.

So in this instance I was actually taking 20 minute subs so therefore my mount was already at least 15 minutes past the meridian when the pier flip dialogue appeared. So ideally it should have flipped when I clicked on the “Attempt Flip Now” button.

I know that it would have flipped if I’d just left it alone - because it always does. If I’d gone to bed & left the sequence to run everything would have been fine. I also know that if I set up a test run, I can execute a manual flip from the control panel using the “Run” button & it will work. It’s just the “Attempt Flip Now” button from the pier flip dialogue box that does not work?

At the end of the day it’s not a show stopper as I do have the option of just leaving it alone. It’s just that occasionally it would come in useful.

Many thanks & regards

My bad, I had misunderstood how you were attempting this.

[07/12/20 01:44:24.467][DEBUG][Pier Flip Thread][SQ;MF;] Meridian Flip: Sending Telescope command to execute meridian flip
[07/12/20 01:44:24.534][DEBUG][Telescope Thread][SQ;MF;] ASCOM Telescope: Pier side is West
[07/12/20 01:44:24.534][DEBUG][Telescope Thread][SQ;MF;] ASCOM Telescope: attempting pier flip using slew
... observatory things.
[07/12/20 01:44:25.257][DEBUG][Telescope Thread][SQ;MF;] Telescope: Slewing to J2000 RA: 19.7171969885506 (19h43m01.91s) Dec: 23.2849704338671 (23°17'05.89")
[07/12/20 01:44:25.257][DEBUG][Telescope Thread][SQ;MF;] Telescope: Slew received J2000 coordinates, mount requires JNOW, converting...
[07/12/20 01:44:25.258][DEBUG][Telescope Thread][SQ;MF;] Telescope: Slewing to JNOW RA: 19.7319444453062 Dec: 23.3344444448619
[07/12/20 01:44:25.258][DEBUG][Telescope Thread][SQ;MF;] Telescope: Calling Observatory Slave Slew
[07/12/20 01:44:25.287][DEBUG][Telescope Thread][SQ;MF;] Caught Exception while querying DestinationSideOfPIer: Method ASCOM.AWR.Telescope DestinationSideOfPier is not implemented in this driver.
... more observatory things
[07/12/20 02:02:42.724][DEBUG][Main Thread][SQ;MF;] Meridian flip was user aborted...
[07/12/20 02:02:42.724][DEBUG][Main Thread][SQ;] Adding sequence level notification: Failed to complete automatic meridian flip, aborting sequence!
[07/12/20 02:02:42.738][DEBUG][Sequence Thread][SQ;] Sending Notification: Error - Failed to complete automatic meridian flip, aborting sequence!
[07/12/20 02:02:42.786][DEBUG][Pier Flip Thread][SQ;] Meridian Flip: Procedure complete
[07/12/20 02:02:48.030][DEBUG][Sequence Thread][SQ;] Blocking Pier Flip: Failed to meridian flip, aborting sequence (True)
[07/12/20 02:02:48.030][DEBUG][Sequence Thread][SQ;] Aborting sequence: Failed to meridian flip
[07/12/20 02:02:48.031][DEBUG][Sequence Thread][SQ;] Set sequence abort

So it seems that SGP started the flip went to slew the observatory and was in the process of slewing the scope. I’m guessing the scope remained at the same location but the dome started to move?


Hi Jared,
Yes I didn’t check absolutely but the dome appeared to be where I would have expected it should be but the scope had not moved. The mount handset indicated it was still tracking . I’ve checked the mounts log file but there is no change to indicate any go-to or flip instruction was received.

I have had the same issue with my AP Mach1GTO. If I allow the auto flip to occur, everything works fine. If I try to have the flip occur between the meridian and the point post-meridian that is set to auto flip, nothing happens and I eventually get a meridian flip failed error notification. I just resolved to be patient and wait for the auto flip.

Hi AstroMike1,
Hi Jared,

OK, so I have now realised the reson for this behaviour. My AWR drive has a feature whereby it will only accept a manual meridian flip i.e. initiated from the hand controller, within a half hour window either side of the meridian (despite what it states in the manual). It will not accept a ‘remote’ flip command within this window, only outside of this window. My mount cannot flip via a remote command before the meridian because the ASCOM driver is not able to set the side of pier. Therefore, for me, with this mount my only option is to setup up the pier flip for any time greater than 30 minutes after the meridian has been crossed.

The reason the “Attempt Flip Now” button does not work for me is because the mount has not reached the minimum 30 minute threshold dictated by my mount. By chance & for the reasons explained in the above post I have always opted for 35 minutes. If I set it for less than 30 minutes the flip will fail. If I wait & click the “Attempt Flip Now” button after 31, 32, 33 minutes etc then it will work.

By the way this only affects the scope & not the dome. The dome will still slew to the correct place regardless, in ‘anticipation’ of the scope following (my dome slews faster than my mount).

I’m not sure if the AP Mach1GTO has any such similar restriction but it may be worth checking?