Auto Focus problem

I have an auto focus problem. Is it possible for someone to have a look at this Logfile. It is quite long but is basically repeated attempts to auto focus.
It used to work perfectly.
Thanks. Adrian

DropBox link

14-09-2015_sg_logfile_20150914213230 - Copy.txt

Doesn’t look like a valid url. Also if you could describe the error you’re having that would be helpful.


Hi Jared.
Thanks for getting back to me. Sorry about the link, I will try again.
I will try and describe the night that the file relates to. I should say that it has worked perfectly in the past but this has been going on for months. I suspect a focuser problem and have changed cables and the hub, but to no avail…
It’s a Baader focuser and the ASCOM program does not hold the focus settings. I have to use the ‘Go To’ in SQpro. and set it to 3000 at the start of a session then go to the focuser and manually wind it back to what I know is near focus. It drives the small wheel so all the steps used appear large (x10). I focus with a mask then run auto focus with a Lum. filter. This may work but is unpredictable. Now this is where it gets strange. I first got focus at 2946 steps, not happy with this I ran again result 2619, ran again 2430, again 2190. I have done this other nights and it keeps descending by about 200 steps each time.
I changed to Ha filter.
A typical run would be. First exposure, nothing showing in the box (no red cross) second nothing. Third, red cross on the base line at zero, one step in from the right edge. Next maybe up to 7. Then it could go anywhere usually up. Run again will not return it to its original position, sometimes 5mm. out on the actual focuser scale. Obviously if I have tried to run a sequence, auto focus aborts it.
I have tried changing the steps but it has always worked in the past at 80. I tried Bin 2x2 in case it was a matrix problem. Increased the number of exposures. Changed AF sample scale.
Sorry to bother you with this, I thought I had had this program long enough to sort things out for myself.
Regards. Adrian

14-09-2015_sg_logfile_20150914213230 - Copy.txt (423.0 KB)

A few interesting bits in the logs. First, your focuser seems to hate when we ask it for position while it is moving… that is odd.

[14/09/2015 21:40:15] [DEBUG] [CP Update Thread] ASCOM Focuser: Error in GetCurrentPosition. : Exception has been thrown by the target of an invocation. (System.Exception: No reply from focuser…)

This does not seem to hurt the AF run though… it’s just a note.

Second thing… your found star counts are a little low ~19-20. This is not a very good number for strong averages. I would increase exposure length.

This can often mean you have actual mechanical slippage or binding. One check you run…

With the scope level, make sure the focuser is fully racked in and reads position 0. Then use the focus controller to rack the focuser out a decent amount ~3/4 of travel. Then send it back to 0 and ensure that it is fully racked in. Also look to see if the motor still pushed after the tube was zeroed. Repeat this a couple of times to see if an error presents itself over time. You can also start with the focuser slightly (visibly) racked out and see if long focuser movements away from and back to the small racked out position eventually seat (zero) the focuser.

Repeat this with the scope vertical.

Of course, all your movements could be fine and your are just getting inconsistent focus results due to inconsistent data.

Hi Ken.

I did a lot of testing yesterday following your recommendations.

Initially in the horizontal position the focuser moved back
and forth over a few thousand steps although after a few moves there seemed to
be 1mm. difference on the scale. I then tried in the vertical position. It lost
the drivers a few times, usually demanding a complete driver reinstall ( I have
to do this so often that I keep it in my downloads folder). Once it could be
fixed by the device manager. Sometimes with it connected and after pressing ‘Go To’ nothing happened, then 5 or 10
seconds later it would start to move. Other times (usually), it did not move at
all. I tried changing the USB cables, made no difference. Completely unpredictable.

I will dismantle it and bring it into the house to try it on
another pc. Of course we have clear skies forecast for the next three nights!

It seems I will have to get in touch with Baader.

Many thanks Ken and Jared, great service from you both as usual.

Regards. Adrian