Auto focus

Hi to you all.

I am having problems with SGP and its auto focus.

I have a Feathertouch focuser with the focuser boss system. Works manually and can be seen in the SGP equipment profile manager. The fine and course controls both work.

However, the RUN control is always greyed out on the focus control panel.

Any ideas on how to get it to turn on the run button.

Yes I have checked use auto focus.



Does it know that it’s an absolute focuser?

You need to connect camera, filter wheel and focuser.

Hi Ken

I have the camera QSI638, filters and focuser connected and SGP sees them all.

Is this 2.3 or 2.4?

It’s 2.3.
Maybe I’ve not selected the right things in setting it up!

I would guess maybe. I have never had any issues with 2.3 on connection to my focuser boss and HSM motor.

Are you connected via USB/Serial or Network?

Connected via usb/serial.
I’ll go back and be very careful.
Just need some fine weather here in Sydney.

Hi CCDMan, are you using the focuser through SGP as ASCOM or FocusLynx?
Just a thought as I have it via FocusLynx.


FocusLynx. Of course FocusLynx will be either “FocusLynx 1” or “FocusLynx 2” with the focuser boss as it can have two focusers attached. It would be “FocusLynx 1” if you have only one focuser attached. Clicking the setup should bring up the FocusLynx Commander focuser setup where you would pick the serial port number.

I have found that, unlike some things (the Alnitak Flat Panel, for example) you can have the FocusLynx Commander controls and SGP connected at the same time (but you can use just SGP, of course).