Auto Meridian Flip did not Occur


I was imaging M82. A meridian flip was supposed to happen. It did not. OTA was on the West side of the pier before the flip. I had SGP set so that the flip would occur 20 minutes past the meridian. SGP’s scope tool showed when the flip would occur, then changed to NA.

I was forced to pause the sequence, pause PHD2, issue a Slew then Center on the target which moved the OTA to the East side. I then restarted PHD guiding and resumed the sequence.

Mark W

Aprox time of issue: Between 11:45 and 11:55 PM

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
.NET: 4.8

Looking at the log the mount reached the meridian a little after 23:23, the next check at 23:26 shows that the mount has changed pier side so a flip is not needed.
If the mount had done a slew just after crossing the meridian then this would explain this but there’s no indication in the SGP log that this has happened. Maybe something else did a slew.
We can’t see the mount, had it changed pier side?

What brand and model is your mount?


I forced the slew using the target dialog. I will try again tonight on the same target.


It is a Celestron CGEM II. Meridian flips have worked in the past. Also, I am using Celestron’s CPWI telescope control application. I will look at the CPWI logs to see if it reported the pier side change without a flip occurring.

The mount crossed the meridian at the time the pier change was reported in the SGP log, but the automatic flip should have occurred 20 minutes later. I forced a flip soon after the automatic flip time.

Mark W


As it turns out, the problem likely lies with CPWI. I just read a report in the Team Celestron forum where the CPWI code reports the pier side change when the target crosses the meridian, not after a slew has occurred. So, SGP was doing what it was supposed to.

Mark W

Found it, there’s a problem with CPWI. The poinitng state is changing as a result of the mount tracking across the meridian. This should not happen because the pointing state has not changed. Pointing state (aka pier side) should only change as a result of the long slew to the other pointing state,

I’ve posted a report in Team Celestron.

I’m also experiencing the exact same issue with my CGX, is there a fix for this yet?

This was an issue with CPWI. I’m not sure if Celestron has addressed this or not but you should definitely update CPWI and/or contact Celestron.



Derik at Celestron posted a new CPWI update that fixed the side of pier reporting error. It looks like meridian flip is working. I have not yet tested it in the field due to clouds and my current target not getting to the meridian before morning light.

Update on 7/10 - meridian flip worked perfectly with updated CPWI.

Mark W