Autofocus Woes

AF in 2.4 has been nothing but a huge headache, so much that I can’t let my sequences run unattended for fear of the system totally screwing the focus. I’m having problems now that I didn’t have before and can’t seem to dial in the settings, especially the sample size. Running at full sample size produces nonsense so I pull down to 15 and get somewhat better results, however the results are still not stable and if the test doesn’t produce a nice “V” curve it just keeps on trucking and keeps moving the focuser, somehow believing that true focus is 1,000 steps from where we started. What takes the cake is tonight I cancelled an AF run that had lost its mind and before the focuser could return to starting position the next frame started integrating.

I usually run 7 data points with 100 steps each @ 4s exposure ISO 800 but I’ve tried lowering ISO and increasing points to no avail. I’m running

I’m hoping this is just user error, but I’m getting wings on my curves and things are generally a hot mess for anything I try to do with AF. Confidence is low.

BTW, I’m trying to image Leo’s Triplet, so maybe I’m just in a bad part of the sky…

Here are some AF packs:

Haven’t looked at your data yet, but have you turned smart focus off? This returns the AF behavior to exactly as it was in 2.3 (your verbiage makes it sound like that was working fine for you).

Thanks Ken. I turned off smart focus and it looks like the system went through 4 AF cycles after I went to bed and initial image reviewed looked pretty good this morning.

Did you catch the point above about canceling out of an automated AF cycle and image integration starting before the focuser had returned to original position? Minor bug?

Smart focus does not work well with all combinations of gear. It seems best at < 1000mm of FL, usually with a refracting scope. Bayer patterns in DSLRs also present problems to auto focus that we need to experiment with in terms of handling.

I did, but I don’t see anything in the code that would cause this and without logs I don’t have much to go on.