Beta 3 timed sequence start not happening and focus issues

I’m running Beta 3 and I tried a timed sequence start, timed for a few minutes time. The time came and went and SGP continued to say it was waiting for the time. Version 2.3 has worked in the past for me.
Beta 2 did the same.
I loaded Beta 3 again.
I restarted SGP but this time I disabled the timed sequence start. I then had further issues and it did not behave as I would have expected. I had the auto adjust per filter and AF on sequence start options enabled, autofocus is with Lum.

The mount slewed round and the slew and center kicked in - but the focuser had not been adjusted for the filter position (this sequence was partially complete and this was a second session, so it was starting with the third event). It managed to plate solve with out of focus stars (impressive!) but then of course PHD2 had problems locking on and calibration failed.

I had to abort, restart everything, manually move the filter to Luminance to move the focuser and then start the sequence for it to get through to A/F and exposure start.

I just tried a few more variations - if I manually move the filter away from Lum, the start of sequence moves the focuser by the focus delta before doing the slew/center.

I think the start of sequence should go to the absolute filter position for the slew/center and then the AF at sequence start can fine tune.


All verified as working fine in 2.4. We will not be able to assist without logs and the sequence file you are using (since we are obviously doing different things). Please see this post:

No problem Ken - log file and video (I was making a video capture at the time to show how clever SGP was…) loaded to dropbox

I have also uploaded the sequence file - but I have altered the order since - it was LLRGBHa with the two L events complete.

The error was entirely consistent. A quick look through the log files seems to indicate a PHD communication issue at 20:10 (links with the video). It also shows the lack of focuser movement (I’m not entirely sure if this is design intent)
After trying this a few times, I manually moved the focuser to the approx position and disabled the timed start, I had no issues with sequencing, with PHD and the auto cycle, calibration and guiding working perfectly.

I have a similar problem with 2.4. If I quit and re-start, the second iteration always works.


I took a look at your logs. The sequence is starting on time, it is that your connection to PHD2 is timing out and I don’t know why. What version of PHD are you using? When I loaded your sequence, with PHD2 2.4.1a open and gear connected (but not running or even calibrated), clicked “Run Sequence”, it waited until the start time, started guiding successfully, waited for the TEC to cool and started the sequence as expected.


While I don’t know why your SGPro was no longer talking to PHD2, I have made changes to promote better user feedback (i.e. it will be very clear that this has happened and you won’t be left thinking this is an issue with the step before it (the delayed start).


Hi Ken. I spent a few hours trying to nail down the sequence start up a bit further this morning: I was using PHD 2.4.1b. I could not get it to reproduce the exact same error - the sequence always woke up at the allotted time, even though I had 5 repeat fails last night. This was the first occasion I let SGP do the guider startup and calibration and so I have not seen this before in any version. However, my trials this morning had repeated issues with PHD2 communications:

I did find some clues:
If I disable auto slew and center, when I run the timed sequence, I get the request message:
“The autoguider is not running or the connection is lost… Would you like to force guider calibration”? after a few seconds. (The server was running)
If autoslew and center are enabled, it does not ask the question and waits for the allotted time and starts the centering process … I’m guessing the connection status is the same regardless of the auto slew/center option and this may be why my system stalled - (the handling of a connection issue with the guider should be handled similarly regardless of the slew and center options?)

I tried to repeat your trial, with PHD2 2.4.1a and did a normal sequence. I got the Guider startup message asking me if I want to force guider calibration again. I reinstalled SGP beta 3/2 and PHD - no change. I enabled the PHD2 debug log - nothing obvious there - it did not see any instruction to loop or calibrate. I’m using Win7 64-bit and the latest updates for .NET ASCOM etc.

I have hundreds of hours of reliable comms between PHD2 and SGP over the last 6 months.

On the initial focus setting - should SGP move the focuser to the stored focus position for that filter when the sequence starts? The help file suggest it should and then move delta’s afterwards between filters.

Just got this note from the Andy Galasso from the PHD forum, which may offer further insight:

I think what happened was that SGP tried to connect to PHD2 at 20:07 before you had started PHD2. It made two attempts (20:07:29 and 20:07:30) and then gave up on phd2.

Right after that you started PHD2 and connected your equipment.

When your 20:10 start time arrived, SGP got tangled up with an error not having a phd2 connection and got stuck:

[10/01/2015 20:10:00] [DEBUG] [Sequence Thread] Checking for start delay…
[10/01/2015 20:10:00] [DEBUG] [Sequence Thread] DoEventGroupChange: Stopping Autoguider
[10/01/2015 20:10:00] [DEBUG] [Sequence Thread] Attempting to stop PHD2 guiding…
[10/01/2015 20:10:00] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : BadConnection

It probably would have worked if you had started phd2 first.

Perhaps in this scenario SG should attempt to re-connecting to PHD2 when the sequence starts?