Beta 316 Issues

Arrows for moving back and forth between images still do not work. There also used to be a Ctrl+Click or some such that would drop a list of the prior images from which you could select one. This no longer works.

Wasnt that right clicking arrows?

This message appears frequently. I can’t figure out what it is complaining about. This has been happening for all versions going back several months.Capture_16bitGreyscale

New temperature compensation not working.

[10/19/19 21:01:36.218][DEBUG] [Sequence Thread] Temperature compensation: Temperature change is -0.899999999999991 degrees (end temp: 43.16 - temp comp marker: 44.06); Requesting relative adjustment of -3 steps…
[10/19/19 21:01:36.218][DEBUG] [Sequence Thread] Temperature compensation: temp_comp_min_step_threshold found (2 steps)
[10/19/19 21:01:36.218][DEBUG] [Sequence Thread] Temperature compensation: Focuser position error not large enough, skipping…

Looks to me like a sign problem. (139.2 KB)

A second problem with the new temp comp routine is it fails to reset its reference temperature when the next auto-focus run is performed.

Beta 316 is still not honoring my request to perform Recovery for the entire night (well 6 hours), so I lost the remainder of the night’s imaging.

Same log file as above: (139.2 KB)

Probably the calculated movement is directly compared to the threshold, and this is wrong: the ABSOLUTE value of the calculated movement has to be compared with the threshold!


Can you provide any more details on when this happens? Does it seem related to any event like when an exposure is complete?

It was… failed to take absolute value and my testing using a simulator produced positive relative changes so looked like it worked.

Yep, this is fixed

@jmacon @entilza

Do you have any additional details on the issue with the arrows? I can’t get mine not to work. Obviously we are looking at different situations.

Ya… this is a dumb error on my part… recovery would always fail on the east.

Not really. They just don’t ever do anything. I click on them, I right click on them, I Ctrl+Click on them, nothing happens. One other user did report this. Can anyone chime in with info that the buttons work for them?

Issue of 16bit error message:
Most nights including last night, maybe all nights I’m not sure, I don’t ever see this in the evening when I am starting the session and then monitoring it for a couple of hours. If I happen to come back to the computer, like early in the morning, the message is there. Actually quit a few of them that I have to click them away. That’s what happened last night. I got up at 4:30, the status of the AG12 which controls the mount was terminated, and there were maybe 5 of those messages. At other times when I have come back to the pc after being away and I want to look at prior images (back when the arrows worked for me), I could click on an arrow and that would pop up this message.

Are the buttons enabled or are they dull and grayed out?

Definitely enabled. Everything looks normal. They don’t enable until I have captured some images.

I don’t mean by this that I always would get the popup. Usually they worked perfectly. Just occasionally would this happen. Not triggered by anything I noticed.

Another thing I just remembered about this funny message issue. Once it pops up, I can’t call up any image from the arrows until I capture a new image. That seems to clear something that it is unhappy about.
I will pay more attention the next time it happens.

I had this happen to me once (HFR and greyscale image message) Beta 307. I can’t say for certain what sequence of events caused it but I had been reviewing some of my images while Plate Solving (or Auto focus … can’t quite remember) routines were running. After that Image Statistics - Stars Found, HFR were NA also Image history reported 0 for these values. The situation recovered when I went to a new target.

Again I have had this happen to me occasionally (beta 307).

I’m sorry I can’t provide any more information on these issues except to say that I also experienced them. Most of the time I do not see them but I will also try to be more vigilant when they happen.



Hi @Ken,

There is an issue when trying to use the Image History Window to mark images as bad or opening them via double click (.313 and .316). It appears that it is placing a double slash at the start and not using an extension:

An addition issue I have only noticed when I installed 316. Not sure if it is a continuing issue with 320.
I was, with 316, having a really hard time getting my selection of User Profile to stay in my sequence. It had been there for many releases. This is easy to know because when you call up the “Planning Tools” from Target Settings, if you don’t have a User Profile selected for the sequence, you get a blank screen and it tells you you don’t have a User Profile selected.

Well prior to 316 I have always had one. I use the Planning Tools a lot. When I installed 316 I no longer had a User Profile selected in my sequence. I use the same sequence all the time. I just add and delete targets as I need to for the night’s imaging. Trying to get it back was a real adventure. It would select. I could use the Planning Tools. Then it would go blank again. That sequence repeated many times. When I loaded 320 tonight neither sequence for either scope had one. So I selected one again. They are there at the moment. We shall see.