Blind Plate Solving using ANSVR

I’ve always used ANSVR for my blind plate solving option


But tonight when I continued with a previously saved sequence SGP took quite a while to complete the initial equipment connection stage, eventually showing a warning dialog stating that ANSVR was selelcted but not configured.

Selecting the Watch ANSVR log suggests that the server address is already in use?

I’ve uninstalled & reinstalled ANSVR but that made no difference.

Clicking the settings button brings up a blank browser page, as does entering manually into my browser.

I’ve not installed any new software or performed any updates recently.

Any suggestions would be much appreciated.

Did Windows change a firewall setting and block Ansvr?

(And, you know, it’s Windows… did you try just rebooting?)

Thank you for replying.
I thought the same as you but I don’t believe the firewall is the problem because today as a test I disabled it. I have also rebooted too.

I’ve also uninstalled ANSVR (Local again, removed all references to, ANSVR & Cygwin from the registry, then reinstalled but this time using ANSVR version 0.22 & port 8082 instead of the default 8080.

Still get the same result though - can’t start the server!

If I type “netstat -ano” at a cmd prompt to see all my active connections does not appear on the list. But according to the ANSVR log 8082 is already in use - but where is it use? I’m not sure how to progress that at the moment.

Do you have 2 instances of ANSVR fighting for the same port?

C:\Users\Jared>netstat -ano | findstr :8080
  TCP               LISTENING       24364

C:\Users\Jared>tasklist /fi "pid eq 24364"

Image Name                     PID Session Name        Session#    Mem Usage
========================= ======== ================ =========== ============
perl.exe                     24364 RDP-Tcp#0                  1      7,152 K

You should be able to do something like the above to determine which process is listening on a certain port. You’ll notice in the above example that it is listening at and not


Hi Jared,

Looks like I only have one

When you view the ANSVR log you’re not attempting to “Start ANSVR” and then “View ANSVR Logs” are you?


Hi Jared,

No, just viewing the log. I have another PC indoors, same stup & that’s fine.

What I get when checking the config is this

On my other PC Iget this

On the PC I have handy just at the moment, I have version 0.20 of ansvr, so I can’t see the exact perl script you’ve got. But, if I could, I’d open it, and see what line 1367 of that perl script is trying to do, inasmuch as that might provide us a clue what’s going wrong.

The file sits in: “C:\Users[whatever_your_user_name_is]\AppData\Local\cygwin_ansvr\opt\ansvr\ansvr”

Where [whatever_your_user_name_is] is, you know, whatever your user name is. The AppData folder is hidden, so you have to set Windows file explorer to be able to “see” hidden folders. And then you’ll need an editor that will let you see line numbers. (gVim will do that.)

[Long rant about the worthlessness of Windows, and the criminal incompetence of its authors, omitted - Editors]

Thank you for the info. I was wondering where the script would be. Makes sense now you point it out. By the way in 2.0 it’s line 1316.

I opened it in Visual Studio & the code reads:-

1316 if (defined($opt_b)) {
1317 $BIND_ADDR = $opt_b;
1318 logmsg(“binding to address $BIND_ADDR”);
1319 }

From the options section of the script opt_b equals the ip address…

-b ADDRESS ip address to accept connections on (default: any address)
Note: use -b to only accept connections from the local machine

Earlier I thought I’d try a system restore, back to before the last lot of Windows updates. It still does not work but the log now reads differently.

So it looks as if ANSVR starts, tries to GET the config (maybe) & then terminates?

Now if I blind platesolve locally


I get


but blind plate solving using the remote option works fine


Normal plate solving works too using ASTAP giving viertually the same answer.


One other thing I noticed is that trying to use ANSVR does not register in my Windows Firewall or Antivirus logs. Temporarily turning off my firewall & antivirus does not make any difference.

I’m not sure where all that leaves me?

OK. So I finally got to the bottom of it by chance really. I could find no differences in settings between my observatory PC & my main PC. But the former had Chrome browser installed & the latter had Mozilla.

Uninstalling Chrome & installing Mozilla fixed it. Re-installing Chrome again prevents me from locally blind plate solving. So with only Mozilla installed it all works fine. I have no idea why but happy days :slight_smile:




Oh yes I re-installed again but sellected the default port 8080 this time instead of 8082. The only reason for this was that I discovered that SGP must store that ina setting somewhere because when you click on the “Settings” button on the “Other Plate Solve Options” dialogue it opened the browser with the address Saved from the original setup I guess?

I couldn’t find where that setting was so it was quicket to re-run ansvr-setup.exe again.

When using the ANSVR (Local Astometry.NET) option, SGP will always use If you want to use a different port you’d have to specify the full ip and port:


This also means that you can use a completely different machine for ANSVR if you happen to have one up and running.


Thank you Jared,

That makes sense & explains a lot.

Odd on my machine that Chrome prevents local blind solving???
I don’t get that at all but it does. This morning I began to doubt what I said so I tried it again. I reinstalled Chrome & local blind plate solving fails. It doesn’t matter if it’s my default browser or not. Just having it installed is enough. Once I’d uninstalled it again local blind solving works???

Anyway, now that I know I don’t care. It’s working :slightly_smiling_face:

That’s odd…I use chrome on all my machines and have no issues with it. But 8080 is a pretty popular port to use as well…maybe a chrome extension you had enabled was causing it?


Yes it’s very odd. On my other machine local blind solving is fine with Chrome installed. It could be extension related. It used to work on my dome PC until recently.

I’ve tried this method of changing the port. No luck I’ve reinstalled and configured ansvr on port 9123, but SGP still sets it to 8080 which is a conflict on any of my machines. When I check the ansvr setting outside SGP it shows port 9123 and the server runs fine. Is there a clear/concise outline of how to use Pinpoint with local Blind Plate Solving via (local) using a port other than the default 8080? Is there an SGP initialization file that can be text edited without screwing with the Registry?

As a very quick follow up and days of trying I’d like to point out whether it’s Unix or Windows, syntax is critical. First go to Tools/Equipment Profile Manager/(select profile)/Plate Solver/ Use blind solve failover/Settings enter address and port AND /api for the configuration web page e.g. in my case doesn’t matter what the port is it won’t connect to or 8080. Adding “/api” is a must. works, doesn’t. I’m sure this is well known, just not to me.