Bug Report: SGP tries meridian flip, does not slew, then crashes if I try to abort

SGP Version:
Symptoms: Sometimes when a target is near the meridian and I start running a sequence containing that target, SGP will slew my telescope and center it on the target to the East of the meridian, then immediately attempt to do a meridian flip. At this point, even though the meridian flip progress indicator states that the telescope is slewing to the target, in actuality the telescope doesn’t even move. After waiting for something to happen (several minutes later), if I click the abort button, SGP just crashes.

So there appears to be 3 issues:

  1. Why doesn’t it slew during a meridian flip sometimes (even though it shows that it is slewing)?
  2. Why does it first slew to the target on the east side of the meridian, then do a meridian flip immediately after even though the object has already passed the meridian 5+ minutes ago? It would be quicker to just directly slew to the west of the meridian.
  3. The crash when I click Abort is unexpected.

Two Logs attached for the same issue (see the end of the logs): Dropbox - File Deleted

I also see this crash on aborting the meridian flip, though the goto on east/west is may be a result of the settings on your mount - if the flip is setup to try before the mount reaches its own limit, it’ll fail in this way.

It is possible… my “minutes past meridian limit” on my mount may be to blame here for the number 2 issue.

I don’t know. This is likely behavior specific to your mount. SGPro just asks it to go to a location, but, in most respects, is not allowed to define “how” the mount should get there.

Sometimes, same answer as above, BUT to your point, SGPro will not request a flip unless you are past for time to flip limit (OR “wait” is checked and SGPro cannot squeeze another frame in in the time remaining before your limit).

This is the same issue as the one you reported in the report about auto centering hanging. This has been fixed.

The reason I bring this up is because I started seeing this behavior after the recent updates. Maybe it is just a coincidence. I’ll check the mount settings to see if I can fix it.


If your mount’s ASCOM driver it writing logs, you can look at the time SGPro requested the slew to see what it was doing (I can help you find that time if you need it). If the driver is not emitting logs, you can usually toggle them on so we can look if it happens again.

Thanks, I’ll try turning on logging and check it the next time this happens.