Bug? "Slave to telescope" is missing in Equipment profile

Today I discover that the Slave to telescope is only available in the control panel. A panel which i don’t use often.

By every new session it’s not checked when you for forget this the roof will not be slaved

This is an important check box that is needed to slave roof with the telescope.
It’s not available in the profile manager of SGP For me it must be always checked.
So this check box must be part of the equipment profile by default

The content of the control panel depends on the profile if I am right the central panel makes it possible to change the setting during an images session.

Control Panel
Screen Shot 2021-03-21 at 13.06.47

Equipment Profile
Screen Shot 2021-04-02 at 13.50.18

Please add this check box also in the Equipment profile manager under the other Tab

Windows 10

This is by design. The profile manager is made to create “templates” for sequence and the “Slave to Telescope” checkbox is an action, not a setting, and cannot be done in the Profile Manager. Same reason there are no “Run Sequence” or “Run Auto Focus” buttons in the Profile Manager. If anything the “Slave to Telescope” should not be a checkbox and should be a button or toggle to make this more obvious.

If you want this to be automatic then you need to check the “Slave on Sequence Start” in the Observatory Settings from within the Profile Manager.


So you say if i check slave on sequence start. Then when the mount parks the roof close and when the mount unparks it opens the roof this is the slave function, which was missing in my config. right?

What is the the aim of the checkbox slave to telescope in the control panel because its by default its off? What brings this action function to me.

Next clear weather i will verify, slave on sequence start. Thanks for your input.


Assuming that all of that is done during the sequence then “Yes”. Basically what happens is when you hit “Run Sequence” it will automatically check the slave box for you.

When checked the Observatory will be slaved to the Telescope. When unchecked it is not slaved. The “Control Panel” is where you go to control your equipment…so any “real time” things go there. The Profile Manager is where you go to create settings that can be reused again and again for multiple sequences.




Because its not checked by default in the control pannel. Does this mean that "Slave on Sequence Start” is disabled and you always must check slave to telescope first before starting the sequence.
in the control panel?

It looks for me a kind of conflict sorry that is not direct clear this relation


The Slave on Sequence Start value will come from whatever you have set in your Equipment Profile. So if you check it then it will populate down to any new sequences in the Control Panel.

If you leave Slave on Sequence Start off then you will manually need to check the Slave To Telescope option in order to slave the two.

Also, keep in mind that you need to click the “Run Sequence” button in order for the two to be slaved when using that option. If you want to do some things like unpark the mount and expect the observatory to follow when NOT running a sequence then you’ll need to manually slave the two by checking the Slave to Telescope option.

Not sure I understand the “conflict” comment.



thanks for the explanation. when the slave sequence start has checked the salve to telescope is greyed out. By Next clear weather i will check the results thank for the support.