Canon 6D and fits

I use SGP for shooting with the Canon 6D and TMB92 telescope. What I use in the format options (FITS, RAW and FITS + RAW) use, photos come in FITS format. Also, the photos I shot for 300 seconds seem to be photon-gathering, just like I gave them 15 seconds. I first installed version, later I used beta version but nothing changed. Where do I make mistakes, can you help me?


Sorry, I’m not sure what you are after here. You have 3 options for how Canon images are saved to disk, 2 of them will produce FITS files

I don’t think we can help much here. So long as your ISO setting is appropriate and the shutter opens and closes when SGPro tells it to (5 minutes apart), then I’m not sure. If SGPro is closing the shutter after 15 seconds despite the 300 sec setting, that is a different issue.

How are you stretching the image to determine a 300 s exposure looks like 15s?

Hi Ken, sorry ı could not explain my first problem, because of my poor english. I tried 3 different formats but i could not get CR2 or RAW format, it gives only fits.

OK. What does happen when you select RAW as the format?

Please see here for instructions on logs:

I read all the related subjects through the forum, but i couldn’t find the similar problem.
When i select the RAW format, SGP gives me the data again FIT format. Thanks for your interest.

OK. I won’t have access to a DSLR until I get home next week, but I’ll take a look. Can you reproduce the problem and send us logs as indicated in the “How to ask for help” post?

Thanks Ken…

Oh, and sending the SGF sequence file you are using will also be helpful.

@derman, I can’t seem to duplicate this. Tried with with both “RAW” and “RAW + FITs” and both output a RAW (CR2) and FITs.

Can you attach your sequence file or profile. Which ever you’re using.


Tonight I took two pictures with RAW + FITS and RAW options in the setting Canon EOS. I could not get again RAW format photos. Dropbox folder has log and sgf files as well as FITS files in both formats. M31 (RAW + FITS) Orion nebula (RAW) came with the option. I also found a file called “cannonRaw-0.tmp” in the Temp (AppData / Local / SequenceGenerator / Temp) folder, maybe it useful. Thank you in advance…


SGPro thinks you have selected the FITS only option (CFA FITS option). As you can see here, SGPro is only attempting to create a FITS file:

[09-Jan-17 20:32:55] [DEBUG] [Sequence Thread] Created full file name: C:\Users\Semra\Pictures\Astrofoto\Winter_2016\Light\

Upon inspecting your sequence file, you also have have it set to output only FITS files. This is from the sequence you sent:

So… how are you setting the option to output RAW files? It does not seem to be getting applied to your sequence. Are you, by chance, adjusting this parameter in the profile manager and not the sequence?

I had this same weird issue when collecting 300s sub frames. One image looked as expected for an exposure of that length. The rest looked like 15s exposures. I was watching the imaging the whole time and nothing seemed out of the ordinary. I checked both the FITS and RAW images and they showed the same issue. I then went back to BYEOS and checked the imaging and had no issues. What is going on here?

If I were to hazard a guess I would guess that it’s something with the mirror lock setting getting out of sync between the camera and SGP. Which is likely because BYEOS automatically sets it and SGP doesn’t.

If you’re using the Mirror Settle in the SGP Canon options you need to manually enable mirror lock in your camera.