Canon DSLR compatability

Has anyone been able to use a Canon 6D DSLR with SGP? I have the a trial of the new beta version So far it will not connect to My Canon 6D.

Hi Duncan, have you installed Canon’s EOS Utilities s/w and tried to connect to the 6D from that? That would confirm that all the USB connectivity is OK but it may also be a pre-requisite to install the device drivers which SGP may need to connect to the 6D (not sure about that).

Thanks for the reply. Yes I do have the EOS Utilities installed and I also have Images Plus and both of those programs work with my 6D perfectly. I also just tried a direct connection (not through the hub) to the 6D and in either connection method I get the same thing. I thought Sequence Gen. Pro. was not connecting because I wasn’t getting any image from the camera but after review what is actually happening is when I start a Frame, and Focus image the camera shutter opens but I don’t get any image, and then both the camera, and SGP get stuck. I have to power off the camera to get the shutter to close, and I have to force SGP to close even though it warns me I still have equipment connected.
Any thoughts on this would be greatly appreciated.

I just connected my 6D MkII. It connected and is working. This means the problem is a compatibility issue with the 6D. The 6D uses DIGIC 5, and the 6D MkII uses DIGIC 7. According to the SGP manual any Canon with DIGIC 3 or better should work but it would appear that may not be the case. This may be a question for Ken, or Jared.

I’ve used 6D with SGP for years so it definitely works with SGP.
Maybe you could try an older version? Even version 2

Thanks for the input. The problem is the whole reason I am trying to use SGP is because I am trying to start using Innovations Foresight Skyguide/Skyguard (full frame guiding with real time autofocus) and only the new beta version of SGP will work with Skyguide, and Skyguard. Up to this point I have been using Images Plus for Image capture but of course it won’t work the new guide/focus programs either.

Older versions of SGPro will definitely not work. Version 3 updated Canon’s libraries to add support for DIGIC 7. We have lots of folks using 6Ds so Im unsure what the issue could be. There might be information in the logs. Info on logs here:

Thanks Ken, OK I am still working on this and here is the latest discovery. My Canon 6D (Non Mark II) DOES work except when I try to use the Live View in the Frame, and Focus window. When I use the Live View it opens the shutter but then gets stuck and I have to turn the cameras power switch off, and force close SGP while it still shows the camera connected.
This may be a glitch in the new beta version of SGP. The good news is the 6D seems to work fine for running a sequence.

I’ve been having a lot of problems for a while now with Frame and Focus (Not Live view) with the Canon 6D. It causes SGP to hang on the first attempt during the first download every time. After I restart, it usually works.