Canon Error Plate Solving


I am trying to center on target, but I am getting a following error (see attached).

A day before everything worked like a charm, but today I just can not do anything. I have restarted my computer many time, camera etc. Nothing helps.

SGP version
Windows 8.
Canon 6D (works just fine with Backyard EOS, so it’s not a camera problem)

Any idea how to make it work ?



sg_logfile_20150418232739.txt (23.5 KB)

Hi Marcin,

Can you get this error consistently or is it intermittent?


Today I am getting this error all night long. And I have tried restarting my computer, restarting and unplugging my camera etc. But (what’s interesting) I did not see this error yesterday - everything just worked. Nothing changed in my hardware/software configuration since yesterday. But now, simply doesn’t work, and so far I see this error consistently.


PS. I can actually run a sequence and then it all works just fine and takes pictures. No issues with a camera. Problem starts when I want to use plate solve. I use installed locally.


Hi Ken,

Any updates on my issue? The problem is still there. Is that something that could be resolved ? Right now I am simply unable to use SGP for plate solving.

Take care,



Your solves are failing because the camera is reporting that it’s busy when we need the plate solve frame:

[2015-04-18 11:31:05 PM] [DEBUG] [Camera Thread] Canon: Error in EdsSetPropertyData (PropID_Tv 0x0C) Error: EDS_ERR_DEVICE_BUSY

Somebody else reported this behavior with certain model Canons so we added code in the 2.4.1 beta to “retry” for up to 30 seconds. I recommend you give that a try.

Hi Ken,

Thanks you for your answer. I will install 2.4.1 beta and see if it helps.

But in the meantime I keep wondering why my camera was reported to be busy. I restarted my computer and my camera, started only EQMOD and SGP and I was still getting the same error. There is a slight chance that something might be running in the background (Eos utility for some reason started when I plugged my camera in - this behavior has been disabled in EOS Utility preferences, but let’s say it run anyway), but then I start BYEOS and it connect to my camera with no problem, indicating that camera is not busy after all. It really confuses me.

For now, I am going to give it a try with an updated software. I hope it will help. If not … I will be back :slight_smile:

Take care,



So … I have installed a new, beta, version of SGP, but it didn’t help. I have then uninstalled completely Canon EOStilities and all camera drivers. Then I have installed a new EOS Utilities 3 and drivers again. Hoping that this could help. It didn’t.

What helped (at least it works so far) was reading your help files (seems like a good ides anyway) regarding “Bulb vs Manual Mode”. My camera was in “M” mode. I have switched it to “B” and now it seems to be working. Any idea why this is happening ?



I have the a very similar problem. But it is not important wich module want to take the picture - even frame and focus “take one” puts this error:

[DEBUG] [Camera Thread] Canon: Error in EdsSetPropertyData (PropID_Tv 0x0C)  Error: EDS_ERR_DEVICE_BUSY

I use a Canon EOS 70Da for this. This problem does not occur with my EOS 500Da.

In some other threads i read someting about mirror lock. I tried every combination (mirror lock in SGPro above zero and mirror lock enabled or disabled and the same with SGPro mirror lock 0) but the problem always exists.

The solution metioned by Marcin (Switch B) does not make any difference.

It is okay in normal sequence but it fails the plate solving, wich is kind of not so good…

Are there any updates about this? Any workarounds?

Thank you very much!



This thread is almost a year old… there have been more changes to SGPro than I can count. For us to help, we will need some things from you. Please see this thread for more information:

Nevermind Ken, i tried to get a nice and clean log for you but as i clicked on “take one” to take a single picture, the error does not occur. This is so weird…

The next time i’ll get this error, i will create a new thread with all the informationen you need. Just for your interest: i got this error in the last beta and the last official release.

Thank you for your time.


The solution key of the unwanted response you are facing is factory reset of your camera. Perform factory reset and then again to do your wanted task. If again the same condition appear then take a time go through Canon EOS 6D Manual and seek more technical support.