Canon problems with beta

I had been successfully testing out an SGP beta version with my Canon t3i. Sorry no longer know which one but I think it was the first to support 12800 iso.

Then I bought an SGP license and installed the latest beta. When I “Take one” I get:

Canon:Error in Get CaptureItem. The process cannot access the file 'C:\Users\dts350z\AppData\Local\SequenceGenerator\canonRaw.tmp` because it is being used by another process


Canon:Error in PressShutterButton for mirror settle Error: EDS_ERR_DEVICE_BUSY

Then the camera is locked up. Killing SGP and trying again I got:

Error connecting to Canon EOS! InvalidArgument=Value of ‘0’ is not valid for ‘SelectedIndex’. Parameter name: SelectedIndex.

Even after power cycling the camera. Only rebooting the laptop and disconnecting and power cycling the camera and reconnecting made the camera usable again by SGP or other capture programs.

Also, On SGP latest beta the camera was making a loud clicking noise I’ve never heard it make before. I know what mirror lock sounds like, I know what shutter release sounds like, and I know what both of them together sound like, but this sounding like maybe the mirror smacking into something it wasn’t supposed to. Scary.

I uninstalled SGP latest beta and went back to the stable release version and the Camera works fine.

Camera also works fine with other astronomy capture programs.

Please advise. I need the 12800 iso support. Which Beta is “Safe” to use with my Canon t3i?


Can you please re-install 2.4, download these DLL files:

Navigate to the Sequence Generator install directory and overwrite the DLLs you find in there with these. We are going to update the distribution DLLs prior to release… just have not done it on the beta yet.

uninstalled 2.3, reinstalled 2.4 latest beta. Downloaded and copied new
Dlls over the ones in the install directory.

Some improvment. Camera is operating, no funny sounds and no lockup,
however I still get the first error when I take one or try to do an
autofocus run.

Canon:Error in Get CaptureItem. The process cannot access the file
'C:\Users\dts350z\AppData\Local\SequenceGenerator\canonRaw.tmp` because it
is being used by another process

I tried deleting the offending file but no luck. The program just created
it again and generates the error.

Log file attached.
sg_logfile_20150220201717.txt (38.4 KB)

This sounds like you have the mirror settle set in SGP and don’t have it enabled in the camera.


I’ll look into that but remember this wasn’t a problem with the 2.3 or the
first 2.4 beta.

Setting the mirror settle to zero did solve the problem, however.

On Sat, Feb 21, 2015 at 8:49 AM, Glenn Newell


If I install beta 15 do I need to also copy the EDSDK-2.14 DLLs over the installation like you had me do for 14?


You don’t. From the release notes:

OK, back to mirror lock. If I enable it in the camera and set a non zero value in SGP I don’t get any downloaded image (Take One). Everything appears normal except I end up with a uniform grey screen.

If I enable it in the camera and set it to zero in SGP, it downloads forever.

So I am still unable to use mirror lock.

Any input here? Anybody successfully using mirror settle time/mirror lock enable with Beta 15 on a Canon DSLR?

Am I doing something wrong or is this a bug?

Not sure. Did you say it was working and now it’s not? It’s hard for to tell based on your responses. Either way, please see this post for information we will need to help: