CEM60 Meridian flip issues

I have a new iOptron CEM60 that I am trying to get working correctly. I upgraded from a Celestron AVX which worked with SGP quite well. I am now have a problem with the meridian flip. I tested it manually during the day and it worked fine. I tried a target that was already west of the meridian and it tried to flip and of course failed because the scope went east and the target wasn’t there. I set up a sequence last night of M33 which started east and watched it flip. It initiated the flip correctly but then started to plate solve before it stopped slewing and the image was all streaks and it failed. I had the recovery option checked so it restarted plate solving a minute later and completed it. I watched it start imaging again and went to bed. When I got up this morning, I find that it failed after two images west of the meridian stating that it failed to meridian flip.

Here is the log:
SGP log

So there appear to be 2 issues here: 1) It either doesn’t know what side of the meridian it is or it is failing to prevent a meridian flip when it reads pier side. 2) It starts the plate solve process after meridian flip too soon and fails because the scope is still moving.

Any ideas?

Another problem - I can’t even start to image west of the meridian unless I uncheck use auto meridian flip. Probably related to issue #1?


Do you set a settling delay? I have mine set pretty high; 30 seconds; due to the meridian flip starting too soon.

Another option is to turn on recovery mode. It’ll attempt to recenter and catches the problem.

I did increase the settling time this morning after noticing the error to see if that will solve the problem of it starting the plate solve too soon.

I do have the recovery mode turned on. It did catch the problem of starting to image too soon and restarted a minute later (as I said in my first post) but it does not solve the problem with it wanting to meridian flip every time the mount is pointed west. I had it set to flip 1 deg after meridian. If I even try to start a sequence east of the meridian (with auto flip checked), it will immediately flip to the east and fail and recovery mode doesn’t kick in. Last night while testing I quickly made a sequence of M57 which was way past meridian. With my AVX I left the auto flip checked all the time. When I started the sequence it plate solved on M57 and focused like it should but instead of starting to image, it flipped the scope to the east and then failed.


I’m seeing your odd behavior in your log which indicates that the mount might be reporting the incorrect side of pier. Can you test the following (it can be during the day) and report back.

1 - Place the scope so that it is on the east side of the pier (pointing west). look in the telescope tab. What does the “Time to Pier Flip” in the Control Panel indicate?
2 - Do the same thing but now put the scope such that it is on the west side of the pier (pointing east). What does the “Time to Pier Flip” say?


With the scope on the east side, looking west, the time to meridian is a negative number and counting up. On the west side, looking east, time to meridian is a positive number and counting down towards zero.


Any further ideas on this?

A possible work around is to have the sequence end just before meridian, let the mount do an automatic flip at meridian, and then have SGP start the same target again a few minutes later. Problem is, the start and stop times would need to be recalculated each night if the intervals were set tight to avoid losing too much imaging time.



When I was having problems with meridian flips, I’d calculate it out every run. It does take a few minutes… frustrating if the CEM60 driver can’t do it correctly.

Hammer IOptron till they fix the driver.

Looking at the help file, it says the telescope module should be reporting a negative number after meridian flip which it does with my CEM60. So doesn’t that indicate the ASCOM driver is reporting it correctly?

Ideas why I can’t do an auto-flip?


So looking at your logs again it appears the mount flipped just fine but that plate solving failed afterwards.

You may try upping the settle time in the telescope tab of the CP so that it will pause before attempting to take an image after flipping. I would start with something like 10 seconds.

You are correct in that it appears the ASCOM driver is ok here. Probably just need to tweak a couple of settings.