Center scope not adjusting rotator

I have my sequence set the rotator to 90 degrees with a 0.1 degree accuracy. It does this when the sequence starts, but after a meridian flip the telescope center routine doesn’t check the rotator error. The dialog box said “NA” for rotator position, but the log file says the angle is 90.11, and syncs the rotator to that.

Shouldn’t the auto center routine also check the rotator angle after a pier flip, and ensure it’s less than the specified limit?

I’m running on a Windows 10, latest build PC.


Do you have it to allow 90 degrees only or plus or minus 180 degrees too like in the picture

90 degrees only.
Should the behavior be any different if I had plus or minus 180?
I don’t want the rotator to ever go higher than 180 degrees due to cord wrap.


Thats how I have mine set and it doesn’t ask me to rotate after meridian flip. I suppose if you want to check rotation you have to change the ±180 to always in the drop down hope that helps.

Mine is set to 90 degrees “Always”. That’s not the issue - the problem is that SGPro doesn’t fix the rotator angle after a meridian flip, even though it’s more than the specified limit away from 90 degrees.


Yes, it should be checking the rotation angle after a flip if the rotator was moved. For the ± 180 option it would not check as the rotator was was not actually moved but for “Always” it should be moving the rotator 180 degrees and validating the error. I’ll double check the behavior.

A log would also be helpful if you have it.


The logfile is at The meridian flip code starts at line 14065 ([01/18/21 04:41:28.539]). The rotator rotated from 0 degrees prior to the flip to 180.12 degrees after the flip (per plate solve on line 14189 @ [01/18/21 04:45:57.801]). My rotator error limit is 0.05 degrees (which shows up as 0.1 degree in the control panel).

Here’s what I saw on the screen - no attempt to fix the rotator error after the flip:

@Jared Any update on this?
I think the auto center routine should ALWAYS check and fix the rotation error - after a meridian flip when SGP moved the rotator, after a meridian flip when SGP did NOT move the rotator, and at the start of a sequence like it does now.

Basically, the “auto center” routine should be “auto center and rotate” when the checkbox to rotate the camera is checked.

My rotation angle doesn’t change a lot after a meridian flip, but some people have mentioned a 3-5 degree change (I assume due to orthogonal or imaging train issues). Always correcting rotation after a meridian flip would solve that.

I don’t think there is any harm in doing this (if you have the value ticked in target settings). We actually handle rotation prior to centering and, because of that, omitted it as a post centering step, but this does not account for mechanical inaccuracies in the rotator. Beta versions and higher will do this.

@Ken, version or ? If the latter, then thanks for implementing!

Typo… 742, not yet released.

@Ken, newer releases still don’t check and fix the rotator angle after a meridian flip. Did you make the change for If so, it’s not working, or we’re talking about different things.

No, not talking about different things. I have checked and verified that this is working as intended and would need logs.

I’m referring to the “Center” dialog box that appears at the beginning of a sequence, after a meridian flip, and during recovery. It centers the object by doing plate solves. When a sequence first starts SGPro checks how many pixels off the object is as well as the angle of the rotator compared to what was specified, and rotates the rotator as needed to get to the target angle.

After a meridian flip and (I’m pretty sure) during recovery, the “Center” dialog box only centers the object - it doesn’t check if the angle is within the user-specified limits. And after a meridian flip the angle is almost always different than before the flip. Depending on the system, it can be off by 1/2 degree to a few degrees.

What are you referring to?

Yes, this is the thing.

As for meridian flip, I tested this yesterday as functional. You should observe a centering and rotating event after flip as long as:

  • In flip options, the option to run the centering routine after flip is checked.
  • For the active target, the option to adjust camera rotation is checked

That said, these routines are non-simplistic and even a small difference in our sequences can cause completely different behavior. As such, logs are the best way forward here.

During a sequence recovery last night the centering of the object worked, but it did not check the angle, which was larger than the tolerance (0.06 degrees versus tolerance of 0.03 degrees).

See the log file snippet around line 230.

Yes, it is true that recovery does not re-adjust camera angle… weren’t we discussing post-flip?

@Ken, LOL. Yes, we were discussing post flip, which is where I thought I was seeing the issue, but I now think it may have been because that’s when the system went into recovery a few times, and did not check the angle.
I’m normally sleeping when it happens so in the morning I only notice that it didn’t rorate after a flip.

If it’s not already on your “to do” list, can you add making sure a “center” action always does an angle check when those two boxes are checked ( they are for me)?

Thanks - Eric