Centre here won't solve, but solve and sync and blind sync do?

I have the local astronomy.net running. Solve and sync, and blind sync work fine. But when I try to do centre here, or even the right click on image plate solve, SGP just hangs for minutes and won’t get past the first attempt to solve.

Any ideas?

Interestingly, the auto meridian flip seemed to work just then.

It appears that it was to do with my plate solver settings. I had set to astronomy.net for both. Setting it to elbrus, and using local astonomy.net for blind fail over all works fine. Sorry.

Hello ,here -plate solve till 25pc accuracy works perfect but if right click center here it solves around the spot…>100pixels away…

Center here doesn’t work with Astrometry.net. It’s a known issue. You have to use Elbrus or Pinpoint for that feature.

Have you tried the Framing and Mosaic Tool? After using it, I would never go back to manually framing my pictures.

While @mads0100 is correct and there is a bug with “center here” for Astrometry.NET, hanging is not it.

Please see this and we’ll see what we can find:

Thanks Mads and Ken. I solved it by installing Elbrus. When I was having the problem, I only had astronomy.net for all plate solving.

Elbrus is rocking and solving fast.

Re: centre here vs mosaic/framing tool. I do have that addon, but hadn’t occurred to me to use it for single images. Had only used it to look at mosaics.

Sorry Mad,
not get notification on this…
meanwhile it works well…plate solve within 25px…
also discoverd recovery mode…will activate it …
is there else an setting where i can tell sgpro to go to homeposition in an abort or failure situation?

Yes, you just tell it in ‘telescope’ tab to park at end of sequence.


I logged in to report exactly the same problem. I notice that when I try the centre here, there is no image scale data, it is set to 0.000.