Connecting everything to SGP

I have read a number of posts on this problem but nothing seems to cover my basic question. SGP can do everything for me once I have got the scope on or near the required target. My problem is getting there. I am using EQMOD powering a Skywatcher HEQ5 mount and two CCDs (main and autoguider) on PHD2. I want to use a planetarium program to control the basic pointing of the scope. The problem is that I can’t connect everything because different applications are already connected. To connect the planetarium program the telescope port is needed. To connect PHD2 the scope port is needed. So what have I missed here? At one time I would have used a hub to gain multiple access but my impression from reading the posts is that this isn’t necessary.
This problem will occur when I am also trying to use my main scope. I am still trying to swap over from Maxim DL (which does it all in one program) to SGP/PHD2/planetarium program but still struggling with basic configuration.
Yes, I have been going through 'SGP - the first week.'

Hi Lawrence,

The EQMOD ASCOM driver supports connections from multiple applications at the same time (planetarium, PHD2, and SGP). Most of the time when people see problems trying to connect multiple apps it is because one or more of the apps is being run as Administrator and others are not. Try to make sure none of the programs are being run as Administrator and it should work.


This is what happened.

Firstly, I have two independent telescope setups. The one referred to here is not EQMOD based.

Using my RCX400+two cameras (SX M25C main camera and Lodestar#2 guide camera) it is easy to connect the scope to PHD2 with both Lodestar#2 and ‘LX200GPS’ (the option instead of RCX400). I can then do any calibration. How did I get to a suitable star? I had to use Maxim to drive to one and then disconnect and reconnect to PHD2.!

So that is how I get there. I then do a PHD2 guidestar calib.

But I cannot connect to anything else when PHD2 is connected. Every try tells me that the ports are not available. Presumably I am running PHD2 in ‘admin’ mode - but how do I identify this and how do I change it?*

So there I am; I cannot use more than opne program at a time with PHD2 which means that until I know what the problem is I cannot get anything else to work.

I did try POTH and Maxim but I don’t need POTH with Maxim because it already does everything (except guide properly…).

Help really appreciated.


Hi Lawrence,
Not an answer (and apologies if you’ve already tried/don’t want to) but is there any particular reason why you have to use the planetarium software? Presumably you’re plate solving so you can use that to sync the mount then slew to wherever you want…


Many ASCOM mount drivers support connections from multiple apps at once. EQMOD is one of them. Could you tell us what ASCOM mount driver you are using for the LX200? If you tell us that, then we can tell you if that is one of the drivers that supports multiple connections. If you’re not sure what driver you are using, you could upload a PHD2 debug log or an SGP log and we will find the answer in there.

If your driver does not support multiple connections, then you’ll need to use one of the hubs included with the ASCOM platform: Generic Hub, or POTH. There is nothing wrong with using one of those hubs, but at the same time there is no point in using them if the driver already supports multiple connections (and they add one more piece of software to the stack). I was using one of the Meade Telescope ASCOM drivers once and it did not support multiple connections so I used Generic Hub, and that solution worked perfectly for me.

When the ASCOM driver does support multiple connections you have to make sure to run all programs as Administrator or none. You have to go out of your way to run as Administrator: right-click the program and select “Run as Administrator”, so if you are not doing that then you are not running as Administrator.

Hope that helps,

Hi Kit
Its a matter of starting off a session. What I have tried to do is to locate a bright star (Altair at the moment) for syncing and focus and then off it goes. However, I am at the early stage of finding my feet (so to speak) and devising a sequence of operations to get a session started. In the absence of any database list of starting targets (bright stars etc) in SGP I have to start somewhere known - hence I thought that a planetarium program might solve this.
Plate solving is throwing up its own problems. I installed Ebrus but so far the settings have been ignored. I will solve that when I get the configuration fixed.
Thanks again.

Thanks Andy - an excellent answer. With the RCX400 mount I am using LX200GPS ASCOM. Last night (typical of other nights), I synced via Maxim and then disconnected. However, SGP etc would not connect, reporting that the port was already allocated - hence the problems for that session. At least I can test configurations during daylight, even PHD2 because it doesn’t have to guide, just connect.
Thanks again - it really is appreciated. :smile:


Hi Lawrence,

Ah, I see.
The reason I asked about the plate solving was that if you had this working, you can use ‘solve and sync’ in the plate solve tab (control panel), so taking an image - wherever you’re pointed - will sync the mount without the need to involve planetarium software.

Whilst it doesn’t help the problem you asked about (sorry!) I just wanted to make sure you were aware of that as a feature.

[You could also use the framing and mosaic wizard to create a target with a bright star in it to use for focusing…]

Sorry I can’t help further!


Ok, AFAICT that driver will only allow one app at a time, so you will need to use either Generic Hub or POTH Hub (both are included with the ASCOM platform.)

Here is how you would set it up:

In one of the apps (PHD2 for example) select Generic Hub (or POTH Hub) as the Mount.

Click the setup button to open the hub configuration. Click Choose Scope and select LX200GPS/R.

Click Ok and you’re done with the setup.

You can now select Generic Hub as the mount in all three programs: PHD2, SGP and your planetarium, and they will all be able to access the mount.


Lovely job! Yes, I chose POTH as a common hub and PHD2 and Maxim both connected to it (daylight) allowing me to roam and therefore focus (at night). Didn’t remember to try SGP but I am sure it will be fine. Curiously, Guide-8/9 would not connect but I am phasing out Guide… This is of course just for the initial focus on a bright star before an SGP session is started. My next challenge is to get a realtime local plate solve working and then Kit’s suggestion will work for me. BTW I don’t know the difference between ‘generic hub’ and POTH but maybe I can find out.


What are the differences between the ASCOM hub and the POTH hub? While you say one can use either, would you have a preference?
Thanks, and sorry to interject into Lawrence’s thread.

Hi Mark,

The best choice is to use neither and persuade your mount’s ASCOM driver developer to update their driver to support multiple connections. Unfortunately that may not be realistic. I don’t think it really matters which of the hubs from the ASCOM platform you choose.

Generic hub is very generic:

POTH seems to have some extra options:

Here’s a third option:


AFAIK EQMOD can accept multiple connections so a hub isn’t needed.

As Andy says not using any additional hub will be the most reliable. One of the primary uses for the ASCOM hubs is to handle synchronising a dome with a mount and SGP does this.


Thanks Andy and Chris.
My effort is in trying to resolve a problem with dec misbehavior (12"LX200 classic). Some time back I tried adding the PHD2 Auxiliary Mount selection for that purpose. I chose POTH hub. More recently this caused a problem with runaway dome behavior. Now there is either no more SGPro conflict, or at least none with the ASCOM Generic hub. Unfortunately the dec problem is still there and likely to be the result of dec bearing stiction.