Connection puzzle

I am having trouble with SGP connecting sometimes. The last two nights saw a camera image download stall which crashed the program. I was using frame and focus - and this has happened before with f/f. A few images downloaded and then it said ‘downloading’ and continued ad nauseum. I clicked ‘stop’ knowing it would crash, which it did. I then disconnected everything and connected the camera via a different USB. On each occasion the device manager showed normal connection but SGP would not connect (error message saying ‘error’).

On an impulse I started a different imaging program that I no longer use … and found that it worked absolutely normally, with downloading images!

This has happened previously. Advice welcomed!

Other query:
Plate solving is working fine but when I click ‘move here’, the scope always moves to the wrong place. Have I missed some process out? A plate solve should know everything about the scope.


Please see here.


OK Jared - sorry.
To clarify: having just restarted imaging after a spell of several weeks of hospitalisation at home I was finally able to power up the scope and equipment a few days back. I got the configuration set up OK finally last night so was ready to calibrate PHD2 for guiding and generate sequences for a simple run. I did a set of flats first during late afternoon. Then after doing the guiding calibrations (with varying results but that is a different forum!) I was ready to take some sample images to test. It was between 20.30pm and a little later so I have located the log file - it was the last log file because of the failure and will attempt to upload - 20kb.
As mentioned before, while using f/f the download froze - as it has done before. Previously I decided that it was a cable failure so I bought a new cable - and it was happening again. After closing the program (and losing the schedule) I restarted the program but it refused to see the camera. After more attemots I closed the program and tried my old (completely different) program. Camera connection was normal and I took a sample image OK with the other program. However, SGP refused to connect to the same camera even after the other program had been closed down.

Lawrencesg_logfile_20170327203209.txt (28.2 KB)

Hi @Lawrence,

Are you sure the logs above are the ones that show this issue? That log shows the successful download of several frames followed by a controlled exit from SGPro (not a freeze or crash).

Meaning you did not save the sequence before closing or something else?

The other software you are using likely uses a native connection and SGPro uses ASCOM. The results show that the camera and cables are fine… Most software allows users to choose to connect to their camera via ASCOM (like SGPro). It would be interesting to see how your camera performs if you try to take ~50 darks using different software via the non-native ASCOM driver.

Hello Ken - and, as always, many thanks for your reply.

Clearly I sent the wrong log, a probable result of not knowing exactly when the problem occured and not being able to read/understand the log contents. I re-visited the log folder to find that the logs had apparently been deleted … but not knowingly by me, so I cannot re-check them.

When this has happened before, the program freezes. Any key touched brings up the totally white screen. There is no option but to close the program down. I have the ‘autosave sequence’ option set but it never (seems to) save anything anyway. My only other option would be to anticipate the possibility of a crash and save the sequence every minute or so before running it.

FWIW the next day all ran fine but that had problems not related to SGP.

Yes, I now realise the other program may have used the native driver instead of ASCOM. I try to keep a standard configuration but I cannot be certain. I could easily do a test download as you suggest.



sg_logfile_20170407095339.txt (40.2 KB)

I have now managed to confirm some problems. This morning I did a repeat of the camera connection problem - see attached log, and it did exactly the same. To eliminate one point made above, the ‘other’ software was using the native driver so that does not count - although I would be sad to have to revert to that every time the problem happens!

A contributing factor to the ‘now I see it - now I don’t’ ascom driver is that I might well have forgotten to power up the USB hub. This was easy to check this morning. However, this is not always the cause of this disconnection.

The second query is the camera cooler disconnection referred to above.

This shows (I think) the camera correctly connected but the cooler has switched off when changing to a very similar sequence. All the sequences have ‘start cooling on connection’ but as reported, it switches off with a warning when changing from one sequence to another. Maybe this is normal?

Lawrence Harris