Controlling my Mach 1GTO

I want to control my Mach1 GTO mount though SGP. I have downloaded the ASCOM AP drivers and I planning on using a USB connection from the mount to the laptop. Is this the right approach? I just tried it but the ASCOM V2 AP driver does not recognize the mount and of course, when I open SGP it does not recognize the mount. I’d appreciate any help to get me headed in the right direction.

I don’t know that any one approach is “right”, but this is exactly the way I do it. USB(Serial) from laptop to mount, AP ASCOM driver, SGP uses said ASCOM driver, off we go.

USUALLY, ime, this is 1 of 2 things :

  • The most likely, given that your post makes it sound like this is a new setup for you, is you haven’t selected the correct COM port.

    • Make sure the mount is powered up, and unplug the USB cable.
    • Run “Device Manager” in Windows. Expand Ports (COM & LPT)
    • Plug in the mount’s USB cable, and see which COM port got added to Ports (COM & LPT) in Device Manager
    • Run “Setup Telescope” from the AP folder, and select that COM port. Use “Check Port” to make sure the mount is found on that port.
    • If you haven’t done so already, adjust any other settings (Locations, etc) in Setup Telescope
    • Start SGP, select the AP ASCOM driver, and connect. Should connect right up.
  • The other likely issue is the USB cable itself is bad. If either no new COM port shows up when you connect the mount, or Setup Telescope doesn’t find the mount on the created port, then that is likely the issue.

If things connect up, and Setup Telescope finds the mount on that port, and SGP still won’t talk to it, then try connecting the mount in the Setup Telescope application, and see if it starts throwing any communication errors.

Got it working. I checked the port in device manager - is was Com 4. It connected and SGP recognized it and the mount moved. Thank you.

1 Like


You’ll find that SGP and the Mach1 seem to get along reasonably well. Enjoy!

1 Like