Date Fit Failure


I use SGP with eqmod and Cartes du ciel. All right, except that the fits are recorded with an earlier date than two hours. This is for both UTC and the observatory. I tried to interface Maxim with the same system (always eqmod and cartes du ciel) but I did not have this problem and i have the right data. Can you help me? Unfortunately this is a serious problem when I do astrometry. I had to modify all the fits by writing two hours earlier and everything then went perfect.
Thank you,


To which date are you referring? DATE-OBS?

Hi Ken!

yes, both DATE-OBS and DATE-LOC… :slight_smile:


My guess is that SGPro was able to successfully query your camera for the date and your camera’s time is not correct (I would need the logs to be sure).


Where can I send you the log?



Just using Dropbox is fine.

Here is the link!


Indeed the camera is providing the time and it is 2 hours off:

[04/19/17 21:47:50.743][DEBUG] [Main Thread] Collecting FITs headers…
[04/19/17 21:47:50.747][DEBUG] [Main Thread] QSI Camera - Camera reports last image start time as: 2017-04-19T19:47:19.928 UTC
[04/19/17 21:47:50.747][DEBUG] [Main Thread] DATE-LOC time provided by camera…

So what do I need to correct in the SGP setup?

I am not really sure. I assume QSI gets it’s time from the local software (from your system clock). So it seems like maybe your machine might be set with the wrong time zone.

It’s strange because I tried it using Maxim and the date of the fit header is correct …