Dome not opening/closing reliably in SGP

  • Scope: SiTech II (Mesu 200)
  • Obs: LesveDomeNet (Uniwersal dome)

I am using Sequence Generator Pro, connecting in SGP my mount directly to SiTechII and my dome to LesveDomeNet (LDN).

Slaving works perfectly.

However, dome OPEN and CLOSE commands in SGP result in odd behaviour.

Typically the dome will not OPEN/CLOSE, or only partially so. Once I saw an OPEN/CLOSE command (can’t remember which one) rotate the dome.

If on the other hand I OPEN/CLOSE the dome from LesveDomeNet, all works as expected.

Problem: I’d like SGP to be able to CLOSE the dome reliably at the end of a sequence, or when the safety monitor says “unsafe”.

Perhaps I misunderstood or missed some parameters.

If anyone uses SGP and LesveDomeNet (and SiTechII), would you kindly advise me on the following:

  • For the dome, LesveDome provides both a PARK and a HOME option. One can choose to “operate at HOME position” or “operate at PARK position”. I have to date operated at HOME position. I am not entirely certain that I understand the difference between the dome HOME and PARK positions.
  • Which one does SGP use? HOME of PARK?
  • The other thing I can think of is that LDN, rather than interpreting my limit switches, uses a time delay to decide whether the dome is open or closed. In my case 120". Would this time delay mess up SGP’s understanding of whether the dome is fully opened or closed.
  • Does SGP close the dome when “disconnecting”? I assume that it does.
  • Is it normal for the scope to park after the dome?

Perhaps a kind soul with a LesveDomeNet dome using SGP could enlighten me, and share his/her start-up and sequence-end work flow for the scope and dome with me.



  • Right now I tried to open the dome twice in quick succession and failed: It opened 10 cm. Closing also failed. It almost closed, but not fully. 5 minutes later I clicked on SGP’s OPEN button: Dome opened perfectly. CLOSE: perfect closure. Repeated OPEN/CLOSE cycle in SGP: Perfect again. Not sure what is going on here.
  • I used to connect SGP via POTH+POTH, but the direct connection using SitechII + LesveDomeNet appears to work well, other than at sequence end.
  • I’ll posted this also on the LesveDome forum.


These types of issues are sometimes difficult to diagnose. In this case, we can certainly assist, but we would need to see both the SGPro logs side by side with the dome’s logs to really understand what’s going on. From SGPro’s perspective, it just asks the dome to do stuff, but has very little insight into “how” that request is handled. Here is information on collecting SGPro logs:

Hi Ken,

Nice to meet you.

I have uploaded two SGP log files to WeTransfer. Kindly see here:
I have no idea where to find the LesveDomeNet log file, so I’ll ask the LDN forum for help on that.

Some further info:
(1) I started with SiTechII and LesveDomeNet being connected from SGP, directly. Slaving works flawlessly. Dome OPEN/CLOSE is very erratic. Sometimes it works after a delay of seconds/minutes. Not sure why. It feels like a software conflict to me, though I have no idea at which level: LDN? ASCOM? SGP? drivers?
The earlier log file, at the very beginning should show some of these OPEN/CLOSE commands which never fully opened/closed the dome.

(2) Around 20:00 I switched the connections to POTH/POTH in SGP, and the OPEN/CLOSE commands execute instantaneously and completely; at least as far as I can tell at this point with a couple of tests. Slaving also appears to work. The later log file relates to this test.

So I may have a work-around, using POTH/POTH. TBC with further tests.

I am leaving my observatory for 6 weeks the day after tomorrow. Any feedback tonight or tomorrow morning EST would be much appreciated. That way I can run some further tests.

Best regards,

Hi Ken,

I found the LesveDome logs.
Please see here:

Thank you,

Hi Ken,

After further tests, I have come to the conclusion that the problem does not reside in SGP, or at least not in SGP alone.

I now also have problems with LesveDomeNet stand-alone. This narrows down the issues somewhat, though definitely not in the direction I thought.

At this point in time I do not know whether I have a new electronics/electrical problem in my shutter motor controls, a new USB problem, or whether a recent Windows 10 update creates intermittent problems for the LesveDomeNet server (or for USB). Interestingly all my other software and hardware appears to be working fine, as far as I can tell.

Should anyone experience recent Windows 10 related issues with LesveDomeNet, I would be interested in hearing about them.

In the mean time, I need to track down the problem from my end. Not easy, as I am 1500 km away for the next several weeks.

I’ll keep you posted.


I run LesveDome software for a roll off, which uses the shutter control and I’m running Win 10, no problems so far for me.

I helped a friend setup his dome with Lesvedome, we found it to never be fully reliable and there is pretty much no support/development so we ended up swtiching to Scopedome.
It probably works ok’ish with a small dome for light use for visual and on location astrophotography, but for unattended/remote astrophotography it’s not to be trusted.

With a large dome Lesveddome will either be inaccurate or very slow because of skipping steps on the encoder, we had to go down to a rotation of 8min with a 4m dome for it to be accurate.
Scopedome works ok with a higher speed at around 90sec per rotation.

Problem solved.

My apologies to the SGP developers.

After further testing, the problem with unreliable opening/closing of my dome was NOT due to SGP. (The timing was unfortunate. The problem started occurring just as I was testing the dome features of SGP.)

The problem was NOT due to LesveDomeNet either, as suggested by a forum member. LesveDomeNet appears to work fine with my dome, and Pierre has always been very helpful.

The problem, as so often before, was with an electrical/electronics component of my UNIWERSAL dome. This time it was the current collector. The current collector is made of 6 spring-loaded contacts (on the rotating part of the dome) which are pressed onto 6 aluminium plates (on the fixed part of the dome). The collector’s springs appear not to press down reliably any more. (The contacts are also cutting grooves into the aluminium plates, as others have experienced.)

For the time being, I have alleviated the problem, but it will no doubt reoccur. I will have to replace the current collector assembly if I want the dome to close reliably in bad weather.

Gradually, like others before me, I am replacing many of the electronic and electrical components of my UNIWERSAL dome. A sad state of affairs…

I have been looking on the internet for a current collector with 6 contacts rated 8A (12VDC). I have not found anything off the shelf. If any of you have bought or assembled something of that kind, would you kindly point me in the right direction?

Thanks to all for your suggestions. Always helpful, even if this time the problem lay elsewhere.

Waiting for the next problem on my astro journey :wink: