Error connecting to ASI294MM camera


I’m trying to connect my ASI294MM Pro camera to SGPro version, and I get the following error message in the Log file:

“[02/22/23 11:14:10.206][DEBUG][Main Thread][NONE] Connecting camera in main thread…
[02/22/23 11:14:18.420][DEBUG][Main Thread][NONE] Connecting camera in main thread…
[02/22/23 11:14:18.433][DEBUG][Main Thread][NONE] Connecting ASCOM camera: ASCOM.ASICamera2.Camera…
[02/22/23 11:14:18.449][DEBUG][Main Thread][NONE] Failed to connect to camera. : CheckDotNetExceptions ASCOM.ASICamera2.Camera ConnectedSet System.Exception: The settings property ‘CamName’ was not found. (See Inner Exception for details) (System.Exception: The settings property ‘CamName’ was not found.)
at ASCOM.DriverAccess.MemberFactory.CheckDotNetExceptions(String memberName, Exception e) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 629
at ASCOM.DriverAccess.MemberFactory.SetTargetInvocationExceptionHandler(String memberName, Exception e) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 646
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type parameterTypes, Object parms) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 372
at ASCOM.DriverAccess.AscomDriver.set_Connected(Boolean value) in C:\ASCOM Build\Export\ASCOM.DriverAccess\AscomDriver.cs:line 163

What I have tried 'till now:

  • tried different USB cables, both USB2.0 and USB3.0
  • updated to the latest ZWO drivers (native + ASCOM drivers)
  • updated to the latest version of ASCOM

It’s strange that when using the camera in SharpCap, everything seems to work fine, but when I try to open the camera in SequenceGenerator Pro I can’t… and the only info I can see is what was pasted above.

Can you please help me resolve this issue ? If there is any more information required, please let me know, and I will provide it.

Thank-you in advance,

Are you connecting via ASCOM in Sharp Cap? I’d give that a try and see if you get a similar issue. That error is coming from the ASCOM driver and not SGP. We’re just bubbling it up.


Hello Jared,

Thank-you for your reply.

Indeed, I have tried both options in SharpCap, meaning opening the camera in direct mode (where the entry ZWO ASI294MM is shown), and also opening via the ASCOM driver (choosing ASI camera 1).
Both option to connect to the camera are working fine in SharpCap.


Coming back to SGP:

  • If I select in the camera drop down list the option “ASI camera 1” (or ASI camera 2), I get the above mentioned error.
  • If I select “ZWO camera” (the option at the bottom of the list), I receive the following error: “Error connecting to ZWO camera! No ZWO camera found”

Strangelly enough, this was done 1 minute later, after closing SharpCap, where the camera was visible, as mentioned above, regardless of how I would connect to it…

So my understanding, up to this point, is that the camera can be accesed in “direct mode” or via the ASCOM driver, at least in SharpCap… So need to understand what do I need to do to get it working in SGP.

Thank-you again for your support,

OK, so in the end I’ve managed to solve the problem.

It’s not a SGPro related issue, and it’s not an ASCOM related issue. It’s a Windows OS problem… having something to do with the fact that .NET 3.5 is not longer enabled on some Win10/Win11 OS releases…

The solution was presented here: Sequence Generator Pro ASI/ASCOM Connection Issue - Beginning Deep Sky Imaging - Cloudy Nights

which points to the SGPro forum, here: ASI/ASCOM Connection Issue - #4 by Ken

Basically I’ve uninstalled everything, meaning the ASCOM platform and all ASI/ZWO drivers, did the .NET 3.5 settings presented above, and installed everything up to date (ASCOM platform + all ZWO ASI were downloaded again, from their websites, to ensure I’m 100% up to date…).

Everything runs fine now, but my OCD tells me I need to keep a close eye on the Windows Features settings, as I have the “Automatic Updates” enabled…

All the best,