Error connecting to QSI

I’ve been a user of SGP for years, although I image intermittently. I have a Windows 7 machine and I was able to connect to my equipment, but then I got a popup saying there was an update. I installed the update, and the update said that I was using a legacy driver for my QSI. So I went to the QSI website and updated the current driver, so it would be compatible, and now I can’t connect. I don’t know if this is an SGP or a QSI issue. I tried installing the legacy software, but still didn’t work.

I have a new Windows 10 computer that I am in the process of moving things over to, and I tried connecting for the first time–didn’t work. Downloaded the new driver, and it still didn’t work.

Anyway, I’m at a bit of a loss. Here are the session logs for my Windows 7 machine. Any ideas? Thanks!


And here are my session logs with my Windows 10 machine.

I have been complaining about latest QSI driver and it does not work for me. Reverting back to legacy driver works fine.

Try uninstalling both legacy and latest QSI drivers and re-install legacy driver.

It’s QSI’s problem, not SGP.


Thanks. I’ll try that and report tomorrow.
Do I download the legacy driver from here? Or is there another site

Don’t you have the original CD disk that came with the camera?


Probably somewhere buried. But I got it working on my Windows 10 machine–not my windows 7 machine. But I’m not going to worry about it as I was moving things to the new machine anyway. Thanks for the help!