Failed to write image to disk on ZWO ASI6200MM

Hi folks:

I have been battling this issue with my ASI6200MM. It happens randomly, the image fails to save on the PC. I have tried it on both a NUC and an Eagle, both relatively simple PCs with Celerons. Is there any advice from the developers team? Anything that can be seen in the logs regarding this error?

Just for info:

This is on USB 3.0 with multiple cables and connected straight to the PC on USB 3.0.


Roger M

I used to get occasional (1 out of maybe 80 images) that would fail to download, using an NUC with a Startech USB 3 hub in between. Since removing the USB hub and adding a Pegasus Powerbox Advance instead, I have had zero download fails, or at least so few in the last two years that I can’t remember.

One test you should try is to use a USB 2 cable instead of USB 3. You won’t lose much at all in terms of download time, and USB 2 is more stable. See if it happens with a USB2 cable.

Hey Joel. Did not know you were a mod here. Good to hear from you.

Biggest issue seems to be with short exposures that can affect autofocus, platesolving, etc but I have lost considerable sections of a sequence. I have tried multiple cables but will give the usb 2.0 cable a chance. Are there any settings that I can try to help from the SGP perspective?

I don’t think so. My understanding is that SGP simply waits for the camera driver to report the download was complete. The download itself is really outside of SGP. I think.

And yes, shorter frequent exposures reveal this more quickly.