Failing to download or capture frames

**The last time I used SGP ( Last night) it was extremely frustrating: after almost flawless performance thus far -last night after updating to the latest version 2 days ago - It just dropped frames probably 50% of the time errors saying it failed to either acquire/save/ download frame. I’m not sure this is exactly due to the latest version, because it did work (mostly) OK the night before.
Co-incident to this I also had many PHD problems such as losing guide star/ low star mass etc. and this caused many images to incorrectly guided and I therefore aborted the sequence many times. - Just adding this for context, I’m no sure if its some memory problem downloading the large images from this camera who’s file size is large. But I have to say it performed OK before taking sequences of 50 or so pics. The seeing last night was much poorer than of late, so not sure if this an issue with the guider then causing a problem with capturing then aborting frames.
First time I’ve posted here - not sure who’s going to see this - I was expecting a help / support response not a forum - great


Aprox time of issue: <Sunday 10PM 5/25/2020 EST USA>

Link to Logs

Useful Info

OS: Microsoft Windows 10 Home
.NET: 4.8

This sort of request for help seems to come up on a regular basis, and 90% of the time the issue is related to a faulty usb cable (they do go bad) or other USB communication issue. The first thing I would try is replacing the cable. But perhaps with all the starts and stops with guiding it did something wonky.

1 Like


Thanks for the quick reply !

I’ll certainly try that couple of questions

Should I have high speed download set as an option in the equipment profile ?

Is the type of USB cable critical ? I do have an extender USB cable on the camera cable and it’s not a new one , but on the other hand it has worked up to now. I also have the guide camera plugged into the hub that’s on the imaging
camera .

Any other settings I should have checked for downloading images from the ASI 6200MCPro

Thanks !


The USB extender is suspect. I would never even attempt to use one.

High speed download in the SGP equipment profile only applies to things like frame and focus and plate solving. An actual light frame as part of a sequence will always be taken at the slow speed because the data is better (even if high speed is enabled).

I also have an ASI6200. I went through three different USB 3.0 cables until I found one that was 100% reliable (I took hundreds of bias and dark frames without issue). But as soon as I used that cable through a high quality powered Startech USB3 hub I started getting random dropped frames. Not a lot but enough to make me connect the camera directly to my mount computer and it has worked 100% reliably ever since.

These new full frame cameras are really taxing systems and software. In my opinion there really isn’t any alternative to a direct connection from computer to camera if you want 100% reliability.

Thanks ! I agree , and I replaced all my cables with USB 3 - I still have an extender but its USB 3 replacing an old one that was probably USB 2
since then 1 dropped frame out of 100. Shortly replacing the extender with a longer USB 3 cable
Thanks for clarifying the high speed setting