Failure on Guiding - PHD2 & SGP


had my first full attempt last night at setting up SGP to automate a quick sequence.

After a few false starts (couldn’t locate PHD Profile etc) I worked out this was a recent bug, and upgraded to 2.4.3beta and PHD2 v2.5.0dev5.

My Setup is an EQ6 Mount, running eqmod, mount hub pro running ascom focuser drivers to a Feathertouch Focuser on a William Optics Megrez 90scope. There is a Pyxis rotator involved, and an SBIG ST11000m camera attached. Guiding is through an external finder guider, and a Lodestar Guide Cam.

I started the sequence on the Helix Nebula. SGP was able to resume the mount from park, slew to target, platesolve to verify and resync using PlateSolve2. From here it rotated the rotator to the correct framing position nominated, and platesolved to verify.

It then started the train sequence in PHD2 - watching from where i was sitting PHD2 did it’s thing - bumped the guide star around and measured it’s movements, verified the directions etc, and locked onto the guide star and started guiding … magic I thought!.

Here is where it all went awry … it cited an error which I neglected to write down (cloudy now so can’t re-verify) but basically implied it was unable to start guiding, and aborted the sequence.

I’m assuming that SGP was waiting for a confirmation command back from PHD2 and wasn’t receiving one.

Can I get a couple of pointers on where best to look - as all started well, but ended quite badly … and I’d dearly love to get SGP out and put it though it’s paces properly …

Please let me know the next steps.


There will be two log files from PHD2 and SGP - take a look at those first. With these kinds of issues, it is very hard to make any assessment. Once you have those files, try and locate the time of the issue and pop them into a dropbox or similar and then ask for help. It is much quicker that way. I was using the same last night (different mount but same version of PHD2 and lodestar) and it worked just fine. One thing to check is the settling criteria - if it was too small, SGP can time out if the guider is unable to get the star to within that value in that time period. I had that when I had drift and and low aggressiveness on the guiding parameters.


Thanks for the reply. That may indeed be the case - whilst it would guide it wasn’t what you’d call settled and was drifting slightly - I’ll pay more attention to the aggressiveness settings etc next time - I may get a opportunity tonight.

Is there a timeout figure in SGP for guiding? If so I may need to tweak this also.

I’ll retrieve the log files hopefully this afternoon.


Taking a guess at what this means, but yes, you can ask SGPro to settle below a particular error (in pixels) for a particular time before continuing the sequence.


Thanks - I had assumed that the criteria for ‘guiding settled’ were simpler than that, such as a timeout value or simple guiding commenced command etc.

I’ll tighten up some of the PHD criteria to ensure it’s quicker to damp the guiding to a regular pattern, and re-try hopefully tonight.



just confirmed by completing a successful run - SGP was able to resume the mount from park, slew to target and sync and align, rotate to required framing angle, complete a focus run, and image successfully (pity about the thin cloud!), home the mount, park and warm up the camera.

The quick solution was to tweak the PHD2 agressiveness settings and it captured guide status quite quickly … thanks again for the prompt assistance.