First Thoughts after moving from APT

Hi All,

Well I chose this evening to switch over to SGP3 from APT, I was very happy with APT but just a little frustrated with a couple of controls that I felt could be improved upon.

Well considering all the messing around I have done this evening and with expected conflicts between various software, I expected SGP3 to crash but it didn’t, so nice one lads.

Cool bits I found when you wanted to mark a sub as bad it then gave you an option to retake a replacement image, that was great.

I like the tabbed images function, makes things a lot easier.

I have heard great things about the Auto Meridian flip, so that will help a lot.

Mild niggle, the stretching of images/auto stretch doesn’t always work and is irritating.

It would be nice if it said what time it was going to finish the sequence rather than how much time is left.

Major Major gripe, why the hell can you not minimise the sequencer so that you can view the images properly, lads come on, you have got to have a really valid reason that I haven’t thought of with that! ;-(

It will be interesting to see how my learning curve progresses, switching from the reliability and ease of use of Metaguide to using PHD2 because I am now using a lodestar x2 which isn’t supported in Metaguide.

Hope I haven’t offended, just trying to give honest feedback.



Just close it. It maintains its state. Or is the Ctrl+W keyboard shortcut to toggle it.


Interesting. I tried several times to even get it to work for me. Finally gave up. PHD2 is awesomely reliable, and VERY easy to use. (Push Here Dummy)

I had a good guide tutor and once I was familiar I never had a problem even in the most adverse of conditions, I wish I could have the best of both programs but that would be being greedy :slight_smile:

CThanks Jared as I operate my pier from about 100 feet away with Tight VNC and keyboard shortcuts don’t always work.

I’ve found a couple of bugs which you are probably aware of: -

  1. The warm up/TEC function is grey out even when the camera is enable, you can set the temp and how long, but you can’t select the two buttons underneath for cool down or warm up.

  2. Sometimes you could change the slider for the stretching and majority of the tiems you couldn’t when using a tabbed image display.

  3. Maybe it is me but found it hard to find an “Equipment Button” when I wanted to just enable certain equipment to change a few things before shut down, is there an equipment menu item that you can pull up at the end of the session to re-initiate or open?

Thanks for your help?

That’s because you’re in Cool Down/Warm Up. If you cancel that then you can directly set the temperature.

I’m not entirely sure what you mean. Adjusting the histogram seems to work no matter how many images I have open.

The Control Panel (pictured below) has all of your equipment settings as they pertain to the sequence. Also you can open Dock Modules for many of the different pieces of equipment and dock them to the sides of SGP.


I would suggest going through some tutorials for SGP as well.

1 Like

I thought APT was magic, but SGPro is something else.

1 Like

A couple of bits,

I was hopeful but was never able to get Metaguide working either. PHD2 seems to work fine over the last couple of years I have used it and the integration with SGP is lovely.

As for remote desktop, I found I like AnyDesk much better than any of the VNC programs or Windows remote desktop. It is a bit processor hungry so your mileage may vary…


Hi Jared,

Still familiarising myself with SGP and it is indeed a very powerful application.

“Sometimes you could change the slider for the stretching and majority of the times you couldn’t when using a tabbed image display.”

It does seem like there is a small bug in the stretching as have tried a number of times, sometimes the autostretch will work and other times it doesn’t which means I have to un-check then recheck the box.

There is a bug of when changing the equipment profile if you leave your mouse over an active pop up area and it pops up with a text prompt, you can’t then press Yes to save and have to either minimise SGP or try and open something else to get to the Yes button, in this instance I could just get to the No button but it meant I lost my changes, you can’t either guess where the yes button is either.

Overlay Bug

Overall I think it is a cracking bit of kit, really quite powerful and adaptive, so thanks for that,

I’m seeing this too, I think for the first time in If I do not have autostretch enabled, it sometimes occurs that I cannot stretch the image on screen using the button on the window, or move the slider either in the histogram tab. If I tab back to the prior image in the sequence, it works, as it then does if I tab forward again to the image that previously refused to stretch. - I’m going to make a unique thread for this one.