Help getting SGP to slave/sync with a Foster Systems AstroMC dome

Looking for help - first time trying to get SGP to control a Foster Systems AstroMC dome. I can connect to the dome and managed to get it to (eventually) open the shutter - although pressing the “Open Shutter” button doesn’t always solicit a response. The “Home” button works. Also, I eventually got the dome to slave seemingly by SGP (ie. in AstroMC the “Dome Slaved” is unchecked, and “AstroMC Manages Dome Az Calculations” is also unchecked).

However, I’m trying to figure out the “Sync” function. I assume I need to uncheck the “Slave to telescope”, manually slew the dome to be centered to the OTA using the green left and right arrows, before selecting “Sync”. It then asks for an angle and I’m not sure what I should be entering here. Perhaps the new dome Az? I’ve tried that and other values but as soon as I re-check “Slave to telescope” the dome slews back to its slightly out-of-sync position.

Also - I couldn’t get the “Close Shutter” button to do anything.

Appreciate any tips.


We’ll need logs to checkout the Open/Close behavior, please see here:

As for the slaving. No, you don’'t need have everything lined up before you click the “Slave” checkbox. You do need to setup your dome in the slave settings so SGP can do the math to figure out where SGP needs to move your dome in relation to your scope:


Hi Jared,
Thanks for the response.

I guess I was hesitant to post a log because I’m not even sure I’m approaching this the way I’m supposed to (ie. expecting it to be user error :smile:) . Although, I guess an Open/Close should be pretty straight forward :=). Here is a log.

sg_logfile_20161009210800.txt (129.4 KB)

I do have the Dome Geometry settings entered. And the “Slave on Sequence Start” is checked. The dome does seem to be slaving to the scope/mount. However, the shutter opening is not quite in alignment with the OTA. In AstroMC there is a “sync to scope” function to address this - I was assuming the “Sync” button in SGP (Control Panel - Other - Observatory) is the equivalent?

I tried looking for more info on the Sync button in the Help file (and forum search), but I couldn’t find info that would explain what I was experiencing. Again - it’s quite possible I’m just not understanding how it is supposed to work.

Dave NL