Help setting up Rigel nSTEP focusing system

Hi Mark,

Thank you so much for the reply. I have no idea how to even access that information on Windows…sorry, I am not a computer savvy lol.

If I search for “device manager” and I open it, I don’t really see anything related to the nSTEP system.

Here is an image of what I see…

Do you mind pointing me in the right direction?

I really appreciate the help!

Sebastian

I don’t access to my observatory computer. It’s interesting, in your image you posted I don’t see an item called "Ports (COM & LPT)"j. That would be where the COM port number(s) would be listed for your COM device. I’m thinking, and don’t quote me on this, that you may need to get into your BIOS to enable ports. I’ve never seen a system that didn’t show “Ports” listed in the Device manager. Below is a small listing from my device manager showing the COM ports.

Ports

I think once you figure out how to get the “Ports” to show up in your Device Manager then you should be able to get your nSTEP system up and running with SGP. Not having the the COM port access is definitely the issue.

Maybe take a look at this link first before going into your BIOS. https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/ports-not-listed-in-device-manager/f5e1dabe-df1c-4262-a912-688c40f75ddd

Regards,
Mark

Very interesting…I noticed that too. However, I was under the impression that all of this had to do with the USB controllers…not the ports.

Now I am even more confused lol. Thank for the link…I will check it out now.

Thanks!

Maybe someone with more knowledge on this might be able to chime in to help, I’m just not real sure. seems like maybe you need to install some additional drivers for your motherboard.
Wish I could be more helpful on this.

Mark

So I followed the link and it worked. Now it does show the port icon I was missing before and it says (com3). That being said, when I connect the usb to the laptop and change the settings in SGP to com3, it still says it cannot connect…mmm…

But we are getting somewhere lol.

Thanks!

Ok, you’re almost there. you need to open up the nSTEP ASCOM driver, I’m going off of memory so I hope I’m telling you correctly, there should be another button on the main nSTEP ASCOM Page that, I thinks says something like settings. that will take you to another popup page of the driver. that is where you should be able to select the COM port. I hope I’m telling you right.

Also, I’ve been helping another person getting his focuser up and running, not the same focuser, but might be helpful once you get your nSTEP connected to SGP. here’s that link Using SGP with Starizona Microtouch and Feathertoucch

Mark

here is where I am

On ASCOM I went to setup and it prompted another window just like you said and it shows serial port COM3

but when I tried connecting through SGP it gave me a few errors

After that, I went back to device manager in Windows and try uninstalling the Port (COM & LPT) icon and installing again (same thing I did with all the USB controllers). However, when I tried refreshing the system, the icon didn’t come up again and now I have no access to it anymore…I definitely screwed up on that one…

Now I am trying to find out how to reinstall the Port (COM & LPT) icon.

Cheers,

Did you try to restart your computer. I think that should bring back your COM ports.

I’m home now, here’s some screen captures from my observatory computer.

COM%20Ports
nSTEP%20%26%20SGP%20image
nSTEP%20%26%20SGP%20image01

For sure you’ll need to get the COM ports back showing in your device manager. Maybe after you get the COM ports back, do a fresh reboot. after the reboot recheck your device manager just to make sure the COM port is still showing then go to SGP and try again.

Not sure why you got the exception error. I’m wondering if two instances were trying to start at the same time? Or I notice in your SGP Equipment there’s GCUSB_nSTEP_2. it’s looks like you may have install nSTEP twice? If you look at my images mine does not have the “_2”. Can you select a different GCUSB_nSTEP without the “_2”?

Mark

I have tried everything to bring the COM ports back but without luck. I have downloaded a bunch of drives, etc and nothing…I think I may have to simply restore the computer to factory settings and install all of the drivers again. I don’t know what else to do.

I double checked and I only have the option for GCUSB_nSTEP_2

Thank you so much for your help…

Cheers

Not sure what happened but at this point it sounds like the right thing to do. Good luck I know that’s a lot of work. give us an update when get things going again.

Mark

Thanks Mark…wish me luck!

I will reset right now and start installing everything back up. I will post an update as soon as I have all the necessary drives installed.

Cheers,

Hi Mark,

So here is where I am today after restoring my laptop to factory settings and reinstalling ASCOM and all drivers for SGP, nSTEP, etc.

I still cannot see the port com3 under device manager…When I connect the USB to the laptop and I try to connect the focuser to SGP, it gives me the same error. This time however, the icon for connection does turn orange after that message which it wasn’t doing yesterday at all. So now it’s almost like if it was connected but I cannot seem to move the focuser to any position.

At this point other drivers such as Polemaster are not working properly either after the reset which is a bummer. I am about to just bite the bullet and purchase another laptop because I am not sure what else to do.

Thanks for you input,

Sebastian

Have you tried plugging into a non USB3 port (Blue centre plastic). Some devices don’t work with the faster USB3 ports

HI there,

Yes, I have connected it to both the USB2 and USB3 with same results.

Thanks

Sorry you are having such a difficult time. This hobby has enough challenges without throwing this in the mix.

A few questions

  1. Do you see the nSTEP icon in your system tray, like the one I show in the image below. If so then the nSTEP ASCOM driver is actually started by SGP.
    System%20Tray

  2. Can you open up the Focus Control? does it show the current position, like this example.
    Focus%20Control

  3. Or are you seeing something like this
    Focus%20Control%20Not%20Connected

  4. Can you open up the ASCOM GCUSB nSTEP driver via SGP? is the serial port showing like this one?
    nSTEP%20Driver%20Dialog

Strange you can’t see your Ports in the device manager. I still think there must be some missing drivers for your mother board.
5. Did you happen to do a Google search for you laptop for drivers?

And your Polemaster is not working properly? I use the Polmaster as well and have not had any issues.

Other then what I mentioned above I’m at a loss. hoping some others might be able to offer some guidance on this one.

Mark

Thanks Mark…I appreciate the empathy =)

Here are screenshots showing what you asked. Please note that the temperature is not being read for some reason.

Again, after opening SGP and trying to connect the focuser to it, it gives me the same error that it cannot connect to COM3 port. However, after I close that dialog box, the icon for connection next to the motor goes orange, suggesting that is connected.

Thank you for taking a look at these.

I have always had issues with the QHY driver for Polemaster. I was running a beta version which was more stable than the last version which kept exiting on me. I will have to simply look for it again…I am not too worry about that one.

Cheers,

Sebastian

I just discovered something interesting which makes me wonder if I had been doing it wrong all along…

So the focuser kit came with two cables, a long cable with only one USB port and a power pin on the other end and also a shorter cable with two USB ports. Until now, I had only been using the longer cable by connecting the power pin to the USB-nSTEP (between the laptop and motor) and the USB port to the USB2 hub of my laptop.

Having said all that, I just tried connecting the shorter cable and when I went to connect, it didn’t give me any errors and the COM3 port in device manager appeared once again!

I am still not able to control it though…I am not sure if this means progress or not LOL

new%204

One more update…So right now I am able to see temperature but not the current position…

Also, after I open SGP, I have to first open the nSTEP icon to be able to have SGP connect to it without getting any errors. After I do this, I am able to see the temperature but not position.

Don’t know how to simply have SGP open the nSTEP without getting errors even though the USB is shown in the device manager under COM3 port.

Ok. Last update of the day…

I was able to sort out the cable issues after talking to Leon Palmer of Rigel.

I can confirm that the motor is working fine in native mode but I am still having issues with SGP.

I can connect through SGP and now the window does show both position and temperature which is great. But I cannot access the setting for the focuser through SGP (it gives me an error message) so I am not sure if I am fully connected. As a matter of fact, the focuser window in SGP does not give me the option of running it (that tab is in grey and cannot be pressed)

new%208