Help with Trying to solve my Meridian Flip Issue

I have a CGEM-DX mount with the Celestron Star Sense system and never had an issue using SGPro automatic Meridian Flip during any of my imaging session on my mount until just recently. The only change that occurred was going from Daylight Savings to Standard time on the Hand Controller. This might just be a coincidence but thought I would mentioned it. Anyway, instead of wasting valuable night time trying to isolate the issue is there a way to test the automatic Meridian Flip using SGPro during the daylight hours to see if I can isolate the cause. Each time it fails I get “Pier Flip Failed” with an ASCOM Exception dialog box, see below.,

I always go to the mount during all flips just to make sure everything goes according to plan. what I noticed when this happens the mount starts it move, then suddenly stops and the pier flip failed messages appears.Again, maybe just a coincidence but all of my flips have always worked up until I change from Daylight Saving to Standard time.

Any suggestions on how to go about testing this during the daylight hours would be greatly appreicated.


While I don’t have an answer for your failed flips I can help you with daylight testing. I used to do this in the house when I was having trouble getting things working right.

Using Stellarium or some other program and pick a target just east of the meridian. Turn off plate solving and any centering functions. Also disable autofocus. Make the sequence with short exposures so you aren’t waiting for the flip. Leave the scope cap on so you don’t inadvertently hit the sun with your sensor. Leave auto flip enabled but again make sure no centering functions are enabled. Then tell SGP to slew to the target and hit run sequence. If you have everything disabled correctly it should take some exposures and then initiate a flip. Just reset to a new target and slew back to try again.


Thanks Chris for the help! I use Stellarium already and your directions looks to be straight forward. Currently raining for the next couple of days so the testing will need to wait, but will try once the rain stops and will report back on what I find.



Please see this and we’ll try and help:

Just a quick update. . .Last night after I got home from work I decided to do some testing on my CG-5 mount which is sitting indoors and doing what Chris @cmassa has suggested. During this test all went according to plan and I had no failures of the pier flip. I did this several times and all were successful. This testing was done without the use of any of the SGPro special features such as AF, plate-solving, or Auto Centering stuff. Anyway, I can rule out the pier flip issue was a Daylight to Standard time change in the hand controller. If the clouds stay away long enough tonight when I get home I can repeat the same testing on the CGEM-DX mount. If the testing is successful without using the AF, Plate-Solving, or Auto Centering in SGPro like it was on the CG-5 mount, I’ll work on adding in each to see if anyone of them might be causing the pier flip issue. If so, I’ll post the log for review.


OK, the clouds stayed away for a little while tonight and I was able to do some testing and the pier flip worked the few times I tried it on the CGEM. However, the clouds moved in before I was able to do the flip with the plate-solving active but never the less a good start. I also learned something else new…I was visiting the TeamCelestron site and ran across a comment by one of the folks on the message board and learned there appears to be a possible bug in the StarSense Hand Controller software that might explain why I started having this pier flip issue. Apparently on CGEM mounts if you wake the system up from hibernation and when it comes time to do a pier flip the mount may want to move in the wrong direction to get to the other side of pier. Apparently where the mount is looking at the time of the pier flip plays a role in this a well. This differently explains the one crash I had, luckily I was at the mount when this happened and was able to kill power. Not so sure if the ASCOM exception popup is related but again this occurred after the mount woke up from hibernation and during the sequence when it was time to do the flip. The good news and bad news: The good; I don’t think the failed pier flip is a SGPro issue, the bad: I’m not going to hibernate the mount until Celestron can fix the issue which means a little more time each nigh doing a mount align.


Can you PLEASE report these StarSense issues to Celestron Support. There are multiple issues round slews and pointing state on StarSense and Celestron is doing nothing about them.

I’ve reported them privately and on TeamCelestron and have been ignored. Apparently they see me as one developer winging about some esoteric feature that no one else will use.

The first I reported was with the Sync command. If it is done after the mount has crossed the meridian the pointing state is changed and subsequent slews go through the wrong pole.

I was told that no one else had reported it. That was because I’ve set the ASCOM driver so it doesn’t trigger this problem. I think I’m going to have to change my driver so that users see this problem. I’ll continue to have the band aid in place but users will have to find and enable it.

So PLEASE PLEASE report this to Celestron Support. An email will do. They do seem to pay attention to emails even if they appear to do nothing.


Hi Chris - I just emailed Celestron support about the issue and posted what I emailed over on the TeamCelestron site. Sorry Ken and Jared for taking up room on this site concerning the Celestron issue, this was not my intent.I thought I had a SGPro issue only to find out it appears to a Celestron problem.