Histogram issue with Canon 1000D

I’m not sure whether this is a SGP bug or user error.

I was helping my brother with taking flats using SGP and his Canon 1000D, I tried all sorts and couldn’t get a sane histogram. I’ve repeated this over two separate sessions and tried varying exposures to try and get to the bottom of this.

These two images show the histogram and image stats for a 0.9s exposure. It’s completely over exposed, yet the histogram shows a thin bar a quarter of the way in. The image stats show it’s saturated at a level of 16147. It looks like the histogram and stats are being displayed in 14 bits.

These two images show the histogram and image stats for a 0.08s exposure. The histogram is way to the left and the stats show an average of 5344. I ended up at this exposure thinking that it was about right - around a 1/3 of the 16147 saturated value I was seeing.

Is there a setting that I haven’t got right?
I don’t want to stretch the histogram, I know about that, I want to know why it appears to not be converting and displaying the data as 16 bit.


You’ll want flat exposures of 2+ seconds when using a DSLR as the shutter does not evenly expose the chip.

Quickly testing this with my RP and it is scaling correctly to 16bpp. Even with the lens cap on I get a thin peak but it’s a little wider than yours. Guess the RP either has more read noise or something was up with that exposure.