How to configure SGP to close dome when SkyAlert signals Unsafe?

Hi, I just installed SkyAlert, and it is running correctly. They tell me that SGP can close the shutter of my Ash Dome if SkyAlert signals that the weather conditions are “Unsafe”. Can someone tell me how to do this?

Here is what I have done so far (per instructions from SkyAlert):


Sequence Generator Pro: Instead of reading the weather file directly, SGP relies on an “ASCOM Safety Monitor” to parse the weather file and report to SGP if conditions are “Safe” or “Unsafe”. The SkyAlert ASCOM Safety Monitor can be downloaded from this [link]


Install the ASCOM SkyAlert Safety Monitor driver.

In SGP, open the ‘Equipment Profile Manager’ and click on the ‘Safety’ drop down menu item. Select the ‘SkyAlert Safety Monitor’ option and then click the ‘Settings’ button.

When the SkyAlert Safety Monitor dialog opens, use the button adjacent to the “Path to weatherdata.txt” label to navigate to the location of the SkyAlert weather data file. Click the ‘Open’ button in the file explorer dialog after selecting the file and then click the ‘OK’ button in the Safety Monitor dialog.


While I was in the ‘Equipment Profile Manager’ in SGP, I also selected my Ash Dome for “Observatory”.

So what now? What else do I have to do to get SGP to close the Ash Dome shutter when the weather file from SkyAlert says that it is cloudy or raining and is therefore “Unsafe”? Please understand, I know nothing about SGP. I just want the dome to close when it rains. Thanks!

SGPro can be configured to run what is called “End of Sequence Actions” when the safety monitor indicates an unsafe condition exists. There are more than a dozen actions that might occur for end of sequence so I won’t link them all here, but I have included the areas concerning the shutter. The important concept here is that the dome must be slaved to the telescope.

Slaving the dome is done from the control panel’s “Other tab” (bottom right). Check the box for “Slave to Telescope”

Then click the “Slave Settings” button. You’re after the setting: “Mount park closes shutter”. Check that and maybe also “Slave on sequence start” if desired.

Finally, you’ll need to configure the sequence to park when done:

check “Park when sequence complete”.

With these settings, an unsafe state will cause the dome shutter to close. You can test by using the “Sequence” > “Run end of sequence actions” menu item