I often see this error - help!? DragDrop registration

On occasion, SGP will crash (maybe once/twice! a night and it’s a major issue because I have to shut down all the other programs and then reboot the computer and restart everything. It would be much better to leave everything running and just re-run SGP. But without a clean reboot of the PC - I get this error. FORCING a full shut down and restart which waste a lot of time. What causes this? Can anyone else run a crashed to OS SGP again without rebooting the machine?


If it’s crashing once or twice a night then you’d be better off trying to cure what’s causing it to crash in the first place.

I get lost in the logs, but if you can make them available here then someone will be along who can no doubt help you further.


is PHD2 already/still running when you start SGP? i have seen similar dialog boxes pop up when i restart SGP but forget to quit the PHD2 that it had previously launched. i just can’t remember if it is the exact same error message.


Am I correct that you only see this error message when you do a restart of SGP after it has crashed? In other words, this message does not come up when SGP crashes? What do you see when SGP crashes?
Are you using Windows?
After SGP crashes, have you tried running other programs? Do any of them trigger this error message?
What version of computer OS are you running and on what hardware?

Also, the suggestion by Starflyer to get to the bottom of why SGP is crashing should be your first priority. SGP rarely if ever crashes for large numbers of SGP users, so there is definitely something out of whack with your setup. My system runs night after night fully unattended without any crashes, running the same version of SGP that you are running.

If SGP crashes, you are probably always going to have to restart all the associated programs such as PHD2.

I’ve been having better luck. A friend told me that if I try to abort plate solve… it can take 15+ seconds to actually abort and move on. Lack of patience on my part… and It seems froze and I do a running tasks and kill SGP. Then I try to restart it (yes with phd and APCC and poth and cloudwatcher running. (else it’s quite a job to shut down and restart everything. Last time I tried it- SGP is start again. (I don’t remember what was different). But when plate solves don’t seem to take place - I click DONE and I find if I wait the 15+ seconds - it eventually goes away and continues.

Patience is not a virtue I was given. But waiting - has eliminated most of these issues.