Is the HFD algorithm FUBAR?

I’m fairly new with SGP but have read a ton and sanity check my settings against the official documentation of SGP… I’m using smart AF with an ASI1600 (native drivers) 2x2 binning, 16px star detect size and 8-10sec exposure times and a step size of 200. My ring is in focus around the 2350 mark, I usually move the focus to 2250-2300 and start the AF routing… I’ll say I’ve got a 80% ratio of focusing successfully, when it is a success I see a perfect almost linear v-curve when it’s not I see random jumps on the sides of the v-curve which mess the overall HFR interpolation.

Even worse is when you’re at focus and run the AF again just for the kick of it… and it screws it up and starts moving to ranges like 2500 and more.

Look at what the algorithm thinks it is a 19.5 HFR image:

OK this is the worst example I’ve gotten so far but it illustrates the issue… but SGP either:

  • Does not detect the out-of-focus star donuts,
  • (or) Detects a couple of non existing stars as 1.2 HFR on a overall image with 8 HFR resulting in a screwed-up v-curve.

I can’t really tell what’s going on or what am I doing wrong, but at first sight it seems that a user customizable outlier removal would help a bit as the star size in pixels is not helpful enough.

I’ve tried building a dark lib… but didn’t had enough time to test it, but from last night I would say that it improved a bit but far from reliable.

Here is another example:

Points 1-6 were complete nonsense, only at step 7 SGP was able to detect the out of focus star donut.

Are you starting with a point that you know is in focus or close to it visually? If not, the system can and will get confused. In my experience, just going to a focus number to start is not adequate - one must do a manual focus at the start of the night.

Why don’t you post an image of a good graph so we know what good is for you.
Also, what scope, FL.
The 20% of the time when it is bad, are you sure you had good weather? Nothing different from times it was good?
You said you are using Smart Focus. With a central obstruction scope you probably want to disable this. That prevents the routine from moving way out of the correct range.

Two things need to be done. 1) Start with your stars at the closest point you can get to perfect focus. 2) expose for longer than you are doing. That last photo shows stars that are just too dim. So if you are shooting 1 second, shoot 5. If you are shooting 5 seconds shoot 10. Also make sure you are binning 2x2.

Let me try to address all your questions.

So I’m imaging at 510mm (600mm with 0.85x reducer) with a refractor, in fact it’s an SW ED80.
I never seen HFR bellow 1.98, last night I get best HFR with the following positions:

  • 23481 2.68 1x1
  • 23483 2.46 1x1
  • 23446 3.03 2x2

I noticed that the success rate of the algorithm is far better when using 1x1 binning. So some issues may come from binning ? ASI1600MMC should be OK at 2x2 binning… right ?

My procedure is to move close the focus point (23500) and start the AF routing with smart focus enabled. I saw on the documentation the remark, as @jmacon also told, that the best results should be without smart focus.

Actually it can be as random as:

  • AF goes good, sets at 23481
  • Accept the AF window
  • Re-run the AF routine and the thing may decide to go wild and just to 25000 range.

Currently weather is really bad and shall go this way for a more couple of days.
As soon as I have the opportunity I’ll get some v-curve snapshots (bad vs good).

With a refractor, the autofocus algorithm is rock solid, particularly for focal lengths under 1500mm. I have had several in the 400mm to 660mm range and the focus curves were always close to perfect, unless some clouds or wind came along.

I am currently using an ASI 1600MMcool, focusing with binning 2x2. Works perfectly.

My guess is you have a hardware issue, such as intermittent slippage somewhere, perhaps related to a particular gear angle. I suggest you do lots of racking of the focuser in x amount then out x amount. Mark the gears with a black mark or tape so you can see where the wheels are moving. After a series in in and outs your physical focus position should end up exactly where it started. If not, there is your problem.

Could it be that this is a mechanical issue? I know that I had some bad curves in the beginning, due to belt tension not being good enough or the wheels being slightly out of alignment.

Algorithm is not fubar and is the best and most consistent I have found.

I have a fsq 106 and curves are very good. That said, the focuser on the 106 went bad and I had to send it in for repairs. What you are describing is very similar to what I experienced with a bad pinion. Curves were not consistent and very random.

I’m not putting aside mechanical issues but I think what we see on the following image should never happen, and for sure it’s independent of the any mechanical issues.

I’ve taken in the past some measurements of HFR vs movement:

  • starting at position 23533
  • going in 5 steps and measure HFR for 5 times
  • repeat 4 times
  • go back to 23533 and measure HRF for 5 times
  • going out 5 steps and measure HFR for 5 times
  • repeat 4 times
  • go back to 23533 and measure HRF 5 times

For each focus position I’ve taken 5 HFR measurements and then calculated the min, max, std and average deviation. Does the following numbers seem normal to you ?

I would echo what CCDMAN said. Some of those images you have shown are completely out of focus and I would say well outside of the range the auto focus routine would work properly (during my entire focus run I would never see any images like this). Take an image before you start the focus run, you should really see normal stars there already i.e. not donuts or worse. If you don’t you might have to use a focus mask or similar to get into better focus to start with.

Also if your focus goes out too much during the end of the run you might have selected a step size that is too large. It would be worth going through the routine to calculate the step size again just to make sure. Also do you have backlash compensation enable? What focuser setup are you using?

Read the manual, calculate your step size, work out and set your backlash, start from a reasonably in focus position and autofocus will just work with a retractor and work extremely accurately.

1 Like

FYI My issues were with focuser slippage.
Nevertheless on a full of noise picture I still believe SGP should not find “random stars”.