Little quirk with Environmental device build 2.5.0.1

Hello there,

Found a little quirk with ref to use of environmental device feature and focuser, use the following SGP
file to test it out:

https://dl.dropboxusercontent.com/u/4938813/HIP%2022783.sgf

This is a basic .sgf file of a star object using simulators so open SGP and open this file as a sequence
and do the following:

  1. ‘Camera’ in equipment should be set to the V2 Simulator, pop into it’s settings and make sure it’s 'Type’
    is set to anything other than ‘Color’

  2. Ensure ‘Focuser’ is set to ‘No Focuser’

  3. Check the Environmental device and ensure this is also set to ‘No Environment Device’

  4. Open the control panel and on the Focuser tab click the button marked ‘Other’ check the box which says
    ’Use environmental device for temperature input’

  5. Connect the mount and cam simulators

  6. Hit ‘Run Sequence’

  7. Clear any user defined message you may have set up and accept that the mount has to be un-parked

  8. Notice the error box that comes up: Error connecting to No Environmental Device ! Object reference not
    set to an instance of an object - Click OK to this box

  9. Next we get the Warning Box: Error connecting to environmental device - Focuser requires environmental
    device temperature input…Continue Anyhow ?.

Two options here as to whether to continue the sequence…Yes or No…If you choose NO then SGP stops the
sequence run…Perfect. On the other hand, if you choose to continue with the sequence by picking YES, SGP
returns to the previous error message shown in point 8. Then, you just go round in circles with these two boxes
forever until you eventually choose NO.

A couple of points about this:

a. No Focuser is connected so surely where it gets it’s temp from is not relevant anyway, Error shouldn’t even come
up ?

b. If you choose YES to the second box to continue the sequence surely it should just continue anyway and just
not take temp input from a device which for this sequence is obviously not picked, this could be an accident of
course so maybe it should warn of this with an abort option for the user but choosing YES should still continue
with the sequence.

Just my thoughts

Regards
Paul

Thanks. Seems reasonable.

Hi, on my very first attempt with SGP I fell into this trap with my TCF-S Optec focuser.
Your reply of almost a year ago(Jan14) offer no solution.
What should I do ?

Thanks in advance,

Jean Guy Moreau
Quebec

Ran into this “error connecting environment device” problem with my Rigel nstep. When I went to run a sequence this error popped up: https://www.dropbox.com/s/y9gc1j0yfpiix0r/enviroment-device-error.png?dl=0

Clicking OK asks if you want to continue anyway, clicking yes just sends things into an endless loop between the two pop up windows. Click no stops it.

I’m not using temp compensation, however, to rid this error message and be able to run my sequences, I had to:

  1. disable focuser
  2. control panel/focus/other and uncheck “use environment device for temperature input”.

After that, enable the focuser and things worked. I was able to run a sequence.

Best,
Shawn

Hi @Shawn

Please send us logs of that show this behavior and the sequence (sgf file). With that we will be able to recreate what you are seeing. Thanks.

Hi, well i still have the same issue with my TCF-s focuser. Unable to use SGP for almost a year.
I thought the new version would correct the problem, apparently no.

“you just go round in circles with these two boxes
forever until you eventually choose NO.”

sg_logfile_20190126105119.txt (31.3 KB)

I tried to disable temp compensation on the focuser itself, no joy.
Please help

Forget it, I was able to get running by resetting in Tools, Options, the problem was getting carried from previous instances. Sorry for the noise.