Losmandy G11 Gemini one meridian flip fails


The meridian flip routine fails,
I’m on my trial to see if SGP will work with my mount.
I’ve attached the logs and also a screen shot of an error the popped up.
The meridian flip works with just the hand controller.

Link to Logs



Useful Info

<I’m running Gemini.net, also tried using Devise hub>

OS: <Win 10 64bit>
Ver: <SGPro version>


Hm, looks like it didn’t like the SideOfPier command:

06/14/21 14:04:48.464][DEBUG][Telescope Thread][SQ;MF;] ASCOM Telescope: Pier side is West
[06/14/21 14:04:48.464][DEBUG][Telescope Thread][SQ;MF;] ASCOM Telescope: attempting pier flip using sideOfPier
[06/14/21 14:04:48.651][DEBUG][Telescope Thread][SQ;MF;] Setting Pier East
[06/14/21 14:04:50.663][DEBUG][Telescope Thread][SQ;MF;] Pier Flip failed when using side of pier: System.NullReferenceException: Object reference not set to an instance of an object.
[06/14/21 14:05:21.368][DEBUG][Telescope Thread][SQ;MF;] ASCOM Telescope: Failed to flip because starting pier side and ending pier side are the same!

You shouldn’t need to run the Device Hub…probably best to remove that from the setup just to reduce the complexity. Maybe let it track farther past the meridian and see if that is successful? Not entirely sure why it’s failing. May be worth going through the Gemini ASCOM settings and seeing if there might be something preventing it.


Hi Jared,
I just tried Device Hub once to see if it would help.
The Gemini.net, ASCOM driver, it setup correctly.
Right now I’m set for tracking 1 minute past just for testing.
I’ll try 5 mins tomorrow and see if that helps.
I’ll let you know.


I ran the routine again and went up all the way to 30 minutes past and it still failed.
It looks like I get the same error.
I appreciate any help you can give me.
I really want SGP to work for me.



I would check your location and time inside of the Gemini ASCOM driver. Maybe the driver and SGP are disagreeing about if the flip is possible? Are you running a generally up to date version of the Gemini driver? Everything seems to be correct in SGP. We’re issuing a command that the driver states it supports and the driver is throwing an error. It may be something that has been addressed in newer version of the ASCOM driver or it may be a misconfiguration of the driver itself.

You can try and run the ASCOM Conform tool to get a second opinion on what is happening.