Lost HFR with autofocus version 2.4


Been a longtime user of SGP, great product. Tonight I just downloaded the latest 2.4 version and was giving it a try. For some reason my autofocus no longer works using HFR, it just returns zeros as the autofocus runs, for now I am using pinpoint to fall back on using FWHM and it is working well. The HFR button no longer works to measure the subs as they come in also. This has always worked great for me, I am sure I am missing something but I am not sure what.




Please have a look at this and we’ll see what we can find. In addition, any AF packs or sample frames would be good too:

Ok I am uploading them now, will post the link shortly. Just ran another focus routine with HFR and it returned zeros like before and when it got to 57% it started all over and moved the focuser out further, Did this 3 times then I stopped it, focused with FWHM and it took right off.

Here is the dropbox link with the AFpacks, AFpack 4 was using pinpoint. I have also included the logfile.


I briefly looked over the logfile, I may not have been seeing enough stars. I use a 2 sec exposure binned 2x2 with a QSI 660 and a FSQ106N, same as previous versions. Unfortunatly clouds have rolled in and I packed everything up, so I will have to test another night.


Will need to dig a little deeper. AFPack1 (at least… have not looked at the others), has plenty of data. When I use your data (it only has 4 frames), I get this (which looks like the start of a good V):

When you see this “0 HFR” behavior, can you r try moving the “AF Sample Size” slider around and then click the star button to see if that changes anything? Also, if that does seem to help, can you share the SGF file you are using?

I did adjust the slider down to minimum with the same result, but I will try again next time out. In the image stats panel hfr also reads NaN, but it says I have some like 330+ stars found in the image. The screen shot that you posted is how it looked on previous versions, the only reason there is 4 frames is that the focus routine stopped and shifted the focus further back, AFpack 2 and 3 are the result.


This is your problem here:

[4/1/2015 8:54:21 PM] [DEBUG] [Main Thread] Calculating HFR with sample size: 0

Is your sequence from SGPro 2.3? Can you send it? I need to see how this value is being set to this.

Yes it was, I was trying to finish it out lastnight. Here is the link.



After many months of bad weather I got my first chance in a long time to go out last night and had this same problem. I was able to fix it in earlier versions, because I use pinpoint, I had to select hhfw or some such method for it to work. I have not tried the slider. Please advise??

Sorry Bruce,

I read your post several times, but I’m not sure how to interpret it. Please see this post for further details on asking for assistance:


I am having the same problem descibed in this thread. I can not use the autofocus, becasue it does not calculate the HFR. When this happened in the past, all I did was change the measurement method that was compatible with Pinpoint. This new version does not seem to give me that option. … Bruce

OK, well you can still choose to use the FWHM version of AF if you want. Other than that we will need logs and AFPacks (all described in the post I linked).

Ok Let me see what I can find. drop box link to sequence below as well as log


The log you posted (I removed it from the post for clarity) did nothing but open and close SGPro. We will need to see the log that shows the AF failure.

My mistake! I found another setting box on the focus control center that allowed me to switch to FWHM and success, Your earlier post indicating I could still chose sent me on the hunt. Thanks for your quick response… Bruce