Manual Rotator not always working

Hey everyone!

I am using Sequence Generator Pro since December 2015 and always had a manual rotator setup in my equipment profile. I also connected it properly during startup of my session.

Strangely the prompt to manually rotate the camera in a certain direction only appeared once during the last 10 months of imaging and I was pretty surprised by it. It was exactly what I was searching for. Now a week later it again does not pop up during plate solve and I somehow cannot get it to show.

Do you guys have any idea what I might be doing wrong here? The rotator element in the main screen tells me the plate solved current rotator position but that prompt would have been great.


Are you telling the sequence that you want to set the image to a particular angle? It prompts you to do this if you use the Framing and Mosaic Tool. There is a checkbox for each sequence you need to select in addition to ‘connecting’ to the manual rotator on the equipment menu.

Yes I am planning my sequences with the framing and mosaic wizard, rotating the field of view to make it fit best. I am not sure how I can look up the angle I set in the final sequence again. Is it the number of degrees in the target window? I could start to manually compare these degrees (if they are the correct ones) with the ones reported from plate solving but I assume using the “rotate your camera” popup would be easier to handle it.

I always thought it gave you a pop up if you have the manual rotator selected and the angle set. Isn’t there a checkbox on the sequence that tells it you want to do it as well?

Yeah I thought the same. Only got it once though during the whole time. In the target settings under “Other” the checkbox for “Rotate camera to: XX degrees” is properly checked. Manual rotator view also reports the plate solved degrees.

I assume the amount of degrees shown in the target settings window are the ones I specified in the framing and mosaic wizard, correct? So compared to my plate solve I about 5 degrees off at the minute. Is there a minimum delta degrees when the pop up is not appearing which I can configure somewhere?

You will only receive a popup dialog if your camera is out of the user defined rotation tolerance. There is no log attached so that’s just a guess.

1 Like

Thanks Ken that was the info I was searching for.

Regarding your attached Announcement, I searched through the manual rotator, rotator and automatic camera rotation pages of the help file and there is no mention of a configurable user defined rotation tolerance.

I have also not yet seen that setting showing up somewhere but I will look again. I believe it would be a good idea to add a link to the page describing the rotation tolerance setting to these help pages.

Since the tolerance is not a property of the rotator, it is not found in any of the rotator’s settings. What you are looking for is here:

Fair point about linking them in the help manual. I will do that quickly.

Tried it last night. Sure enough if you’re out of tolerance if tells you. Otherwise it’s good to go. The manual rotator feature is pretty cool.

Thanks all! Yeah I kept looking for the setting in the rotator area. Did not think about searching for it in the Plate Solver, now it seems logical to place it there. Issue solved :slight_smile:

1 Like