Meade LX200 not working with plate solving

I have an LX200ACF mount that I am running with SGP. I have just about everything working and ran my first multi target sequence last night. Outside of not having the focuser setting optimized for autofocus - which I think I have fixed - the one remaining issues is that I cant seem to use plate solve to fine tune my target position. It is not a problem with plate solving. I am using pinpoint and plate solving works just fine. The issue is that when the plate solve is finish, the mount dose not seem to use the data to improve its position and targeting/framing. I am using Cartes du Ceil and i can get it to update and sync the RA/DEC position to the mount, but SGP seem to not be able to do this. I can only run a sequence with a slew to target only. My go-to’s are pretty good so I get most object reasonable centered if I have synced a few stars relatively near even right in the center of the frame. Is this an issue with the Meade itself? I have read several posts on the weaken of the Meade software and ASCOM driver. Is there anything I can do for fix this? I can send the log files if you need them.

This is “modeling”. SGPro does not attempt to do this. If your mount driver uses modeling, there is no real reason it can’t be used with SGPro.

SGPro does do this. When a plate solve completes, it will sync your mount through the exposed ASCOM interface. Note that this requires the “Sync Behavior” option on the telescope tab is set to “Sync”.

I guess that I did not explain this well. When I use the frame and mosaic wizard, After I choose the target, fetch the image, draw the rectangle and frame the target, I then choose to add the target to the sequence. When I do so, the popup has three option for “Slew to target and center”. If I choose “precision centering with plate solve” I get errors when I run the sequence and SGP tried to precision center. I can plate solve without issue and finds to current RA/DEC. But when it tries to center on the target RA/DEC from where the plate solve determined that the scope was actually pointing, the sequence errors stating that it cant center on the target. I dont remember the exact wording of the error. I will have to capture it the next time I try it out.


When you are able to reproduce the issue, please see here to collect the information we will require to help:

here is the section of the log file with the error:

[04/25/17 03:42:32.691][DEBUG] [PHD2 Listener Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[04/25/17 03:42:32.729][DEBUG] [Telescope Thread] Checking to see if solve might be bad…
[04/25/17 03:42:33.226][DEBUG] [Telescope Thread] Solve appears to be good…
[04/25/17 03:42:33.226][DEBUG] [Telescope Thread] Auto center validation frame solved successfully…
[04/25/17 03:42:33.226][DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 14.0443069030662 Dec: 54.2203308173919
[04/25/17 03:42:33.226][DEBUG] [Telescope Thread] Telescope: Sync behavior set to “Sync”…
[04/25/17 03:42:33.230][DEBUG] [Telescope Thread] Telescope: Sync Passed in J2000 but mount requires JNOW, converting…
[04/25/17 03:42:33.231][DEBUG] [Telescope Thread] Telescope: Syncing to JNOW RA: 14.0548611316816 Dec: 54.1389127834364
[04/25/17 03:42:33.397][DEBUG] [Telescope Thread] Attempting to write fits header info for C:\Users\Christopher Foster\AppData\Local\SequenceGenerator\Temp\
[04/25/17 03:42:33.398][DEBUG] [Telescope Thread] Opening fits file…
[04/25/17 03:42:33.408][DEBUG] [Telescope Thread] Successfully opened fits file…
[04/25/17 03:42:33.408][DEBUG] [Telescope Thread] Writing fits headers…
[04/25/17 03:42:33.408][DEBUG] [Telescope Thread] Closing fits file
[04/25/17 03:42:33.408][DEBUG] [Telescope Thread] Could not sync the rotator to 354.0027 degrees (not connected)!
[04/25/17 03:42:33.411][DEBUG] [Telescope Thread] Auto center complete…
[04/25/17 03:42:33.582][DEBUG] [Center Scope Thread] Unable to achieve results below allowable error (50 px) in 1 attempts!
[04/25/17 03:42:33.582][DEBUG] [Center Scope Thread] RA Error: -99.8
[04/25/17 03:42:33.582][DEBUG] [Center Scope Thread] DEC Error: 145.2
[04/25/17 03:42:45.207][DEBUG] [Sequence Thread] Something has gone wrong when centering the target, but recovery mode is NOT active!
[04/25/17 03:42:45.207][DEBUG] [Sequence Thread] Adding sequence level notification: Something has gone wrong when centering the target, but recovery mode is NOT active!
[04/25/17 03:42:45.208][DEBUG] [Sequence Thread] Error on auto center, aborting sequence!
[04/25/17 03:43:32.800][DEBUG] [PHD2 Listener Thread] PHD2 - No messages received from PHD2 for 1 minute, checking socket with status…
[04/25/17 03:43:32.800][DEBUG] [PHD2 Listener Thread] Checking PHD2 state…
[04/25/17 03:43:32.800][DEBUG] [PHD2 Listener Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[04/25/17 03:43:32.800][DEBUG] [PHD2 Listener Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

Looks like it solved just fine but your settings for auto center aren’t working for your mount. I’d recommend more attempts. Currently you have it set for 50pixels but only a single attempt. You likely need to up the attempts (I personally use 3). You can find this in the plate solve tab of the control panel and equipment profile.


OK. That seems easy. If this works, then I have resolved almost all my


Just for follow up, I have now been successful with full three target automatic sequencing with go to, plate solving, fine tuning targeting, autofocus and image acquisition using SGP!

Thanks for all the help!