Meridian flip early morning even if meridian is far away

Hi everybody.

Never had this problem before i updated to latest release
I am located in Poland - was imaginag NGC7822, meridian flip worked correctly at 21:02 and the sequence was planned to finish around 05:00 in the morning.

After meridian flip the info in SGP said ‘Time to pier flip: NA’ because that is correct, i was already on east side and no flip was coming anymore.

But at 02:59, the ‘Time to pier flip’ changed in SGP from NA to ‘-5:55:12 and 21:04’. This equals to exactly the next flip.
And sure enough, after the current frame finished, it tried flipping the mount, and obviously the mount refused…

This happened 3 times in a row, on 3 different targets (IC1805, M31 and NGC7822)

I use AZEQ6 with EQMOD. EQMod setting has ‘Pier side’ set to physical, has worked perfectly until now.
P.s. i have a problem with EFW2 filter not wanting to change filter, and i only have this with this ‘false meridian flip’. Can not confirm if this is related or another issue.

There is some strange timedelay in the logs, for me this all occured at 02:59.

Logs are here:
[02.11.2015 03:12:23] [DEBUG] [Sequence Thread] Checking for auto manual focus (post)…
[02.11.2015 03:12:23] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[02.11.2015 03:12:23] [DEBUG] [Sequence Thread] Attempting to move to next event…
[02.11.2015 03:12:23] [DEBUG] [Sequence Thread] Attempting to find next event…
[02.11.2015 03:12:23] [DEBUG] [Sequence Thread] Current event[0] frame count: 12/20…
[02.11.2015 03:12:23] [DEBUG] [Sequence Thread] Current event event[0] has remaining frames. Returning current event.
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Running capture event…
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] ------------- Starting capture frame for event[0] -------------
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Sending commands…
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] SetFlatBox: Frame Type is Light
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] TEMP - Current Event2: 0
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Checking if Meridian Flip is needed
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Telescope is on the West side of the mount
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Meridian Flip needed, Hour Angle >= Degrees Past To Flip: 93,0136871260425 >= 1
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Running blocking meridian flip…
[02.11.2015 03:12:24] [DEBUG] [Pier Flip Thread] Meridian Flip: Starting Meridian Flip Procedure
[02.11.2015 03:12:24] [DEBUG] [Pier Flip Thread] Meridian Flip: Calling SGM_TELESCOPE_SOLVE
[02.11.2015 03:12:24] [DEBUG] [Pier Flip Thread] Meridian flip: Waiting for scope solve to complete…
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] SGM_TELESCOPE_SOLVE message received…
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Telescope solve with plate solver Astrometry.NET
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Setting filter for scope sync…
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Setting filter position 1…
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Setting filter: Lum…
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Moving filter wheel, isMoving, check 1…
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Moving filter wheel, isMoving, check 1 is complete…
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Adjust focuser pos per filter: Moving focsuer to focus position (21800)…
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Focuser moving to 22674
[02.11.2015 03:12:24] [DEBUG] [Telescope Thread] Focuser move call complete
[02.11.2015 03:12:26] [DEBUG] [Telescope Thread] Focuser position matches requested position (22674), continuing…
[02.11.2015 03:12:26] [DEBUG] [Telescope Thread] focuser move is complete…
[02.11.2015 03:12:26] [DEBUG] [Telescope Thread] Moving filter wheel, isMoving, check 2…

If you could zip and attach (or share with dropbox) the entire log that would be helpful.

This post details what is most helpful to us when addressing issues:

Jared (106.5 KB)

sorry, didn’t know the rules here yet :smile:
Attached is the whole log.

I’ve got a second one if you then also require that (1 day later same happened)

P.s. it seems very similar to this problem: Unnecessary Meridian Flip - Failed this would though contradict that its because of SGP version. But i was imaging same targets, and this has never happened before. I also did not update any software other software before this incident.

Kind regards, Graem

I am not really certain. This might be a question best addressed to your mount’s driver author or the (EQMOD community). Without any input or instruction from SGPro, sometime during this 22 minute time span, your mount decided it was on the other side of the pier.

At 02:11:

[02.11.2015 02:50:39] [DEBUG] [Sequence Thread] Checking if Meridian Flip is needed
[02.11.2015 02:50:39] [DEBUG] [Sequence Thread] Meridian flip not needed, telescope on East side

Then at 03:12:

[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Checking if Meridian Flip is needed
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Telescope is on the West side of the mount
[02.11.2015 03:12:24] [DEBUG] [Sequence Thread] Meridian Flip needed, Hour Angle >= Degrees Past To Flip: 93,0136871260425 >= 1

I had this happen once before. I was running with an older version of EQMOD and they have recently made some changes to the pier side. I updated and haven’t had a problem since. However, that could also be a coincidence as it only happened once before.

Make sure you get your version from the files area in the EQMOD Yahoo group. There are a number of versions on the net that are old and often appear to be the latest version.

Hi Ken & Tim.

Looking at the security-camera it seems that this ‘issue’ happens exactly when the mount is crossing the (i don’t know how to say this differently) park position. So yes - the mount IS changing pier side, but thats correct behavior? (I was on West until hit meridian - flipped to east and then continued imaging, and then you will end up on the west side again if you image long enough)
But in my opinion i just ‘started’ entering the west side, and am not at the meridian. Or am i totally missunderstanding smth?

@Tim what version of EQMod are you currently running? I’m on latest stable (1.27l)

My workaround for now is to disable automeridian flipping in SGP if i know that i’ll not hit it again, but don’t like these ghosts in the software unsolved.

Kind regards, Graem

Hi Graem - I am not sure what they consider stable but they have issued 15 releases since 1.27l. They are at 1.28k. In 1.27p they implemented " Pierside reporting swapped." I have no idea what that meant but considering I was having a Pierside issue I included it. Most of the releases I’m referring to are small single issue updates. I just went on their Yahoo group and in the file section they tell whats in each release. When I see a feature I want or need I just update to that level.

Hi Tim.

Uch, very strange.
I just checked their website and under ‘Downloads’ you get to the official SourceForge Site:

and there latest stable is 1.27l.

Where did you get to the other official site with the newest releases?

Kind regards & thx for helping.

Hi Graem,

Join their Yahoo group and under “files” they list all their releases. Each release seems to fix or add a single issue. I was also on 1.27l but when I saw the pierside change I updated. I haven’t had a problem since. However, as i indicated this only happened once so it may have been a coincidence. However, I would certainly recommend you try it.

Hi Tim.

Great, will do that. I don’t really understand the release cycle of eqascom, but guess its got some logic :smile:
But obviously love it!

Kind regards, Graem

I just wanted to quickly update this thread.

It works with latest EQmod (1.28k) if setting PierSideReporting to ‘Version 1.24g’. Then SGP works correctly.
What i do not understand though - is that eqmod clearly states that the 1.24g pier reporting algorithm is not ascom compliant.

Will have to further investigate this.

Kind regards, Graem

To all the EQMOD users out there. Download the ASCOM conformance checker at

Run it and find out whether the version/mount you are using is ASCOM compliant. You can run all the tests or just selected tests. SGP will do flips correctly if the compliance test passes. Even though a flip may work at any given time does not mean the driver is compliant for all cases.

I’ve posted a pointing state test application I’ve been working on in the files area of ASCOM-Talk. You need to be registered to get access to it, the URL is

This may also help, it does more extensive tests around pointing state and pier flip than Conform does. From what I’ve seen while Conform is good it doesn’t pick up all the side of pier issues and will tend to report that things are right when SGP will fail.

My tests seems to show that EQMOD 1.28k is OK in the northern hemisphere with the PierSide mode set to either V1.24g or pointing. They are both wrong in the southern Hemisphere.

Hi Chris & DesertSky.

Thx a lot. Yes i am in the northern hemisphere and have done countless tests in the last few days. It seems to work with this workaround with 1.24g pierside setting.

Will try the PierSideTest asap.

Kind regards, Graem