Meridian Flip issue: "Time to pier flip: NA"

I’m in the process of looking how the iEQ45 mount (first batch) with hand controller 8006 works with SGP.

My question is: in my profile and control panel I’ve selected to Use the Auto Meridian Flip; however when looking in the Telescope tab in the control panel it says “Time to pier flip: NA”. You can see how it is in this image:

Last night when I was under the stars I tried the meridian flip, but nothing happened. Is this because of the NA parameter in the Time to pier Flip? How this can be solved?

Thanks for your help

It might be possible that the scope may have already be pointing to West side of Meridian, therefore no flipping is necessary. I know you said you tried to perform Meridian Flip but are you sure the scope was pointing East of Meridian before crossing the Meridian?


That’s what shows when a flip is not required.

I can confirm the mount was pointing to the east, before reaching the meridian. In fact, before slewing to an object, at its home position, the time to the pier flip is reported. This issue is present after slewing to an object on the east.

If I slew to the west, the Time to pier flip increases!! As if it was pointing to east.

After both of your posts I selected “Reverse E/W” under the telescope tan in Control panel, but I found the same behavior.

Any ideas?

It’s possible that there may be a bug in the mount’s ASCOM driver by not providing correct information to SGP. You might want to contact iOptron. Also you might want to upload your logs so others can analyze the data.


Here is the log as suggested by Peter of the work done today:

sg_logfile_20141120175715.txt (26.6 KB)

Any ideas to solve this would be appreciated.


I am having the same issue. When I check the Use Auto Meridian Flip option, the Time to Meridian value changes to NA.


This thread is almost 2.5 years old and is not really relevant any longer.

Please see here:

And here:

And here:


I had already checked SGP’s instruction manual and read the sections related to this topic before I posted my comments. I followed the recommended settings but with no avail.The screenshots clearly show that there is over an hour to Meridian time, but when I check the Use Auto Meridian Flip check box the Time to Pier Flip value changes to NA. As soon as I uncheck the Auto Meridian Flip option, the Time to Pier Flip value changes back to it’s actual value.The fact that NA is displayed would not bother me, but the flip would not occur. If you have any recommendations beyond what can be found in the links you posted, which like I said I have already applied, I would appreciate it.

It seems there one thing that I have not done yet: updating EQMOD from 1.27 to 1.28. I’ll give that a shot next time. Thx.

I have also found this thread on the forum that seems to be quite helpful. Thanks for getting back to me anyway.