Meridian Flip - SGP crashes, repeatable

Every time SGP fails to perform a meridian flip, I’m getting this. Logs attached for v2.8.2.8.

Looks like you aborted in the logs. This is some type of low level communication error with a device that is causing this crash. We would need corresponding ASCOM equipment logs to be sure.

Also… if “view problem details” has any info in it, it might be useful.

Hey Ken,

I had this error thrown when I tried it this time:

It gave me a quick pop up ASCOM error as well “Command Timed Out”.

Did anything change with meridian flips and I had them working just fine until I upgraded recently.

No, not directly. There were some changes made to the code that opens closes shutter on domes… @Jared made those. Not sure if they would affect flip. In the logs, what device does it say issued the timeout?

Also, is here: is here:

If you want to use them, uninstall completely.

17:53:25.368 IT:SideOfPier.Get TID:11 [Enter] pierWest, -7.52
17:53:25.368 IT:SideOfPier.Set TID:11 [Enter] pierEast
17:53:25.368 Transmitting commands TID:7 [2]: :Mf#
17:53:25.368 TransmitUDP packet#, cmd TID:7 [0]: 2440, :Mf#
17:53:25.369 Done transmitting TID:7 [2]:
17:53:25.369 Ethernet wait for respons TID:7 [0]: :Mf#
17:53:25.370 getUDPCommandResult recei TID:7 [2]: G#
17:53:25.370 Ethernet Received TID:7 [0]: :Mf#
17:53:25.370 Ethernet received: TID:7 [0]: :Mf#, G#
17:53:25.370 Ethernet wait for respons TID:7 [0]:
17:53:25.806 IT:Connected.Get TID:10 [Enter] True
17:53:25.809 IT:CanPark.Get TID:10 [Enter] True
17:53:25.820 IT:AtPark.Get TID:10 [Enter] False
17:53:25.830 IT:Tracking.Get TID:10 [Enter] True
17:53:30.104 IT:CanSlewAsync.Get TID:10 [Enter] True
17:53:30.114 IT:RightAscention.Get TID:10 [Enter] 14.995589
17:53:30.114 IT:Declination.Get TID:10 [Enter] -6.857326
17:53:30.134 IT:Altitude.Get TID:10 [Enter] 38.984159
17:53:30.134 IT:Azimuth.Get TID:10 [Enter] 183.985923
17:53:30.145 IT:SiderealTime.Get TID:10 [Enter] 15.203568
17:53:50.146 IT:SideOfPier.Get TID:10 [Enter] pierUnknown, System.TimeoutException: Mechanical Declination[0D][0A] at ASCOM.GeminiTelescope.GeminiHardwareBase.get_MechanicalDeclination() in c:\proj\GeminiUpdateDriver\GeminiTelescope\GeminiHardware.cs:line 4703[0D][0A] at ASCOM.GeminiTelescope.Telescope.get_SideOfPier() in c:\proj\GeminiUpdateDriver\Telescope\Driver.cs:line 1817
17:53:50.147 IT:CanSlewAsync.Get TID:10 [Enter] True

Here is what I’m getting… apparently it’s timing out when it slews but reporting that it accomplished it?


Nothing changed that would affect the flip. Looks like your driver is timing out. I’ve noticed weird behavior on my Gemini 1 when slewing before. Sometimes the driver would even timeout but I can’t recall ever seeing a timeout in the ASCOM driver.

Might want to post this in the Gemini Ascom Driver group.


Thanks Jared. It’s pretty repeatable… one stupid question for you (or anyone who knows), is there a way to put in a 30 minute pause in a sequence? I’d like to plan for the meridian flip… pause it… then restart the sequence after I know the object is well past that point and start again. Or, would it be better to just task it to another object for that hour?

Sounds stupid… just trying to maximize my imaging time while I figure this out.


You can set the sequence to pause prior to a meridian flip and it will sit there waiting for you. Which is what I think you’re looking for.


1 Like

Thanks Jared!


So surprisingly enough (or not) it was cable drag. My declination cable had become wedged next to my pier and it was loose enough for most spews but not enough for a meridian flip.

Wife fixed it and I’m back in business. Guess I should take those heavy TR messages more seriously. Thanks for the help!